Multilingual form - second language form not functioning correctly

%3CLINGO-SUB%20id%3D%22lingo-sub-1889828%22%20slang%3D%22en-US%22%3EMultilingual%20form%20-%20second%20language%20form%20not%20functioning%20correctly%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1889828%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSTRONG%3ESituation%3A%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3EMultilingual%20form%20made%20with%20several%20multiple%20choice%20questions.%20Based%20on%20the%20answers%20you%20are%20forwarded%20to%20a%20next%20question%20using%20branching.%20Furthermore%2C%20the%20answers%20for%20each%20question%20are%20shown%20in%20random%20order.%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20primary%20language%20is%20Dutch.%20All%20questions%20and%20answers%20are%20translated%20to%20English%20with%20the%20option%20%22Multilingual%22.%26nbsp%3B%3CSPAN%3EThe%20form%20is%20functioning%20as%20it%20should%20for%20the%20primary%20language.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EIssue%3A%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3EUsers%20of%20the%20form%20in%20English%20are%20forwarded%20to%20wrong%20branches%20%2F%20questions%20based%20on%20the%20answers%20they%20have%20given.%20A%20while%20ago%20the%20form%20was%20functioning%20correctly%20in%20English%2C%20however%20since%20a%20while%20it%20is%20not%20functioning%20correctly%20anymore.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20test%20this%20myself%2C%20i%20experience%20the%20same%20problems.%20When%20choosing%20an%20answer%20of%20a%20multiple%20choice%20question%20and%20repeatedly%20refreshing%20the%20page%2C%20the%20same%20%3CU%3EDutch%3C%2FU%3E%20answer%20remains%20selected%20(although%20the%20answer%20appears%20at%20different%20positions%20because%20of%20the%20random%20order).%3CBR%20%2F%3EWhen%20adding%26nbsp%3B%22%3CEM%3E%26amp%3Blang%3Den-gb%22%20%3C%2FEM%3Eto%20the%20weblink%2C%20the%20questions%20appear%20in%20English%2C%20as%20they%20should.%20However%2C%20when%20I%20keep%20refreshing%20the%20page%20a%20different%20answer%20is%20chosen%20each%20time.%20Somehow%20the%20English%20translation%20does%20not%20match%20the%20right%20%22Dutch%22%20answer.%20Very%20frustrating.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1889828%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EForms%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Forms%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMultilingual%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Visitor

Situation:

Multilingual form made with several multiple choice questions. Based on the answers you are forwarded to a next question using branching. Furthermore, the answers for each question are shown in random order. 

The primary language is Dutch. All questions and answers are translated to English with the option "Multilingual". The form is functioning as it should for the primary language.

 

Issue:

Users of the form in English are forwarded to wrong branches / questions based on the answers they have given. A while ago the form was functioning correctly in English, however since a while it is not functioning correctly anymore.

 

When I test this myself, i experience the same problems. When choosing an answer of a multiple choice question and repeatedly refreshing the page, the same Dutch answer remains selected (although the answer appears at different positions because of the random order).
When adding "&lang=en-gb" to the weblink, the questions appear in English, as they should. However, when I keep refreshing the page a different answer is chosen each time. Somehow the English translation does not match the right "Dutch" answer. Very frustrating.

0 Replies