MS Forms Not Saving forms or quizzes

Copper Contributor

I am a paying customer for Office 365 and have access to MS Forms.  Whenever I try creating a new form, the form is not saved.  I have seen other threads on this topic but no solution was posted.  The only way to edit the form is thru accessing the form thru my history.  When I refresh MS forms, the form is gone.


I have used MS Forms in corporate setting and have not experienced this issue.  


is this a bug or is there something I can do to resolve this? 



8 Replies
I have been experiencing the same issue since last week. Initially, when I created the form it saved everything. Then all of a sudden I would get the error message: "Some of your changes were not saved. Please check your network connection or try again later." There's nothing wrong with my network connection - everything else that requires the network works just fine.
Same thing happened to few collegues withing our company, different forms.
I have no idea what went wrog, but i seriously consider not using it in important business processes


I contacted MS support and have been working with them for two months to get it fixed but they're still working on the issue. I did find out that it works fine on my Mac; it's just my PC that gives the errors.

Same issue using Edge. Tried it in chrome and worked perfectly. Interesting MS forms not compatible with MS Edge. ;)

@jordi_jedi I found that it depends on the browser and the device. My Dell will allow me to use Forms in Firefox but not Chrome or Edge. My Mac will allow me to use Forms in Chrome (I haven't tried Safari). I opened a ticket with Microsoft about this issue in January and their backend team is still working on it. They told me to use Firefox for the time being.

Have you fond a fix for this

I have had a ticket in for a while now and I keep getting the same responce. This is not and exchange issue it is the App department @ysizzle 

@Sean_Downey_Windmist I switched to using google forms :-).  Didn’t have time nor patience to wait for a fix.  

@Sean_Downey_Windmist Mine works now and I'm using Edge on my Dell laptop; however, I've done a few system wipes because of issues with other MS settings, so perhaps that could have something to do with why Forms works now.