Forms will not load for all

New Contributor

We have created a form that we wish to get responses from.  We emailed out the link, but have run into a problem where it will not load for some users.  They have tried IE (I know, its outdated, but its what we have) and Chrome.  It will load the "circle of death" or loading circle and just keep spinning.  On one PC I was able to go directly into the form through the form editor, but it still would not load when following the link.  

8 Replies
Hi Brandon Jones,

This page confirms the browsers

So you should be ok with IE as it’s 10+ and chrome, but as noted latest versions of the browsers help. I would also test on the browsers to see if there is any setting or third party extension impacting the rendering of the form.

But a quick and easy way to get around this should be to add Forms via the Teams Desktop client as either a Forms Tab or a Web Tab by entering the URL. You could have the users impacted in a Team, or set up an org wide team and add as a Tab. It’s should be an effective method if added as a web tab too as the rendering of web pages in Teams is independent of the browser on the users machine.

Hope that answers your question!

Best, Chris

@BrandonJones - Having a similar problem. The survey opens in Edge but not in Chrome (The dotted wheel keeps spinning)...

We have tried different forms, different links and we get the same results. People who were able to open the forms now cannot, it is just the spinning dots.

@Christopher Hoard I am having the same problem. I share a form to another user for editing and just dark screen with spinning circle

If you are still having issues after this, I would personally raise a ticket to Microsoft support

Best, Chris

@Christopher Hoard  I am still facing the same issue. I have cleared cache, restarted browser, laptop. Even does not open for me. I have tried on Chrome, Firefox latest and stable versions.

On going to the browser console, I am able to see these errors:



I have seen almost all the discussions related to this topic but nothing has been able to solve the issue for me.

OS/Platform : Ubuntu 18.04 LTS







same problem here ...

When I use sections (next page) in a questionnaire, Forms does not load in specific computers. Below is a printout in console with sections. 



Workaround was to remove sections and number of questions. After that the form was working as expected. With a functioning form, console printout:


Tested browser is Microsoft Edge (Version 85.0.564.63 64-bit). OS is Windows 10 Enterprise, version 1709.16299.2107.


Interestingly, the form functions well with original number of questions and sections in another computer outputting the former console content (see the first pic). Browser in the other computer is Microsoft Edge (Version 85.0.564.63 64-bit) and OS Windows 10 Enterprise, version 1709.16299.2107.