Forms Pro won't register emailed invitations

%3CLINGO-SUB%20id%3D%22lingo-sub-564253%22%20slang%3D%22en-US%22%3EForms%20Pro%20won't%20register%20emailed%20invitations%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-564253%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20trying%20a%20Forms%20Pro%20survey%20out%20for%20our%20Net%20Promoter%20Score%20survey%20and%20am%20sending%20invites%20via%20the%20built-in%20email%20function.%26nbsp%3B%20Recipients%20are%20receiving%20the%20invitation%2C%20completing%20the%20survey%2C%20and%20I'm%20receiving%20an%20email%20notification%20that%20the%20survey%20is%20complete.%26nbsp%3B%20When%20I%20go%20to%20my%20forms%20page%20and%20look%20at%20the%20tile%20for%20that%20form%2C%20it%20shows%20that%20there%20are%20a%20number%20of%20responses%20on%20the%20bottom%20of%20the%20tile.%26nbsp%3B%20However%2C%20when%20I%20click%20into%20the%20form%20it%20shows%20that%20no%20email%20invitations%20have%20been%20sent%20and%20that%20there%20are%20no%20responses.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20it%20possible%20that%20I've%20set%20this%20up%20incorrectly%3F%26nbsp%3B%20Or%20is%20the%20survey%20not%20fully%20functioning%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-564253%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EForms%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Forms%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESurvey%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-566384%22%20slang%3D%22en-US%22%3ERe%3A%20Forms%20Pro%20won't%20register%20emailed%20invitations%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-566384%22%20slang%3D%22en-US%22%3E%3CP%3EUpdate%3A%26nbsp%3B%20The%20responses%20showed%20up%20today%2C%20but%20Forms%20Pro%20is%20still%20not%20registering%20email%20invitations%20sent.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I'm trying a Forms Pro survey out for our Net Promoter Score survey and am sending invites via the built-in email function.  Recipients are receiving the invitation, completing the survey, and I'm receiving an email notification that the survey is complete.  When I go to my forms page and look at the tile for that form, it shows that there are a number of responses on the bottom of the tile.  However, when I click into the form it shows that no email invitations have been sent and that there are no responses.  

 

Is it possible that I've set this up incorrectly?  Or is the survey not fully functioning? 

1 Reply
Highlighted

Update:  The responses showed up today, but Forms Pro is still not registering email invitations sent.