FORMS PRO: Branching not working when user returns to a survey after starting it

Copper Contributor


I'm hoping you can help me with an issue a few of my users are seeing.


  • I have a single survey with several variables that must be filled out by 3 stakeholder groups.
  • The first question in my survey is "Select your stakeholder group"
    Based on that selection and branching rules, stakeholder group 1 will see 10 questions, stakeholder group 2 will see 3 questions, and stakeholder group 3 just one question
  • Because there is some overlap between the questions for the stakeholders - the business owner of this survey wanted to order the questions in a logical format.
    • All Quality questions first - n=6 (SH1 answers all these, SH2 answers only 1, SH3 answers none)
    • Next all Cost Questions n=2 (SH1 answers 2, SH2 answers answers none, SH3 answers 1)
    • Finally all Service questions n= 2 (SH1 answers only 2, SH2 answers 2)
  • All the branching rules work well for 90% of the users - there are 2 users that see something strange when they "return" to a survey they have already started
    • Suppose they are a member of the SH2 group - when they return to the survey it starts insitu as expected; however, these users will see Costs questions they should not based upon the branching.

  • Note: all surveys are customized for each user (unique url, and they are allowed only one answer)

So my question are these:


  1. Has anyone seen this behavior when returning insitu to surveys? Is it an issue with browser history?
  2.  Is there something I need to consider when creating my branching rules to address the situation of returning users?
5 Replies
I have the exact same issue.

635 unique individual Forms Pro survey links prepared and email using Flow every week.

Majority (90%+) of users complete survey on mobile devices (phones and or tablets)

All respondents are users with microsoft 365 accounts.

When respondent exits survey and then returns, branching rules are 'broken'. Respondents return to last survey section/question open.

Error: Questions that should be hidden are visible. Hidden questions are 'required' but only when branching rules make them visible.

Work around: Respondent presses embedded back button and returns to first question. Change status of first question, all branching rules are reset and error clears.

This requires urgent fix. Please. This is causing a high level disruption and users are entering poor data as a result.

@RussellRNZ - I am seeing something similar. I've got a Form that I'm displaying via a SharePoint embed. Within this form I've setup branching on the first question. Once they select the answer for Q#1 it should result in them seeing additional questions (if they select A as branching questions 2-6 show, however if they select B, questions 7-12 show). However what I'm finding is that half the time when a user loads the form they end up starting at question #2 and see Q#2 - Q#6. They don't see Q#1 at all and can't change Q#1 to get the right branching logic. 


I've tried to republish the page where the Form is embedded. I've tried deleting the Form web part and reloading a new web part linking to the same form. I've tried to switch how question #1 is displayed. I even tried to add a question before Q#1 without branching to see if that fixes or helps with anything. My next test is to delete question #1 and try to rebuild a new question in it's place.





I have raised this issue with Microsoft. It has been escalated through several teams. I was able to reproduce the branching errors on a Microsoft tenant.


I have been advised that this issue will be resolved in the Late September(ish) - Early October(ish) 2020 Forms Pro update.

@RussellRNZ - From your response I newly realized that this thread was specific to Forms Pro. I'm also seeing this in standard Forms application. Any awareness if the timeline you outlined also applies to base Forms app?

@J_Robinson All you have to do is, at the end of Section 1(bottom of section 1) where it says GO TO, Choose 'End of the Form', by default 'Next' is selected. It will solve your issue.

I was having the similar issue and tried every single way however nothing seemed to work well for me. However the solution above did the trick for me. Try and let me know whether it solved your problem or not. Hope it help! Cheers.