Forms crashes when trying to collect answers

Brass Contributor

There seems to be an issue where the webapp crashes in the collect answers part. Specifically when the invitation submit form is displayed (see screenshot). The app just hangs.
Seems to happen in various browsers.

35 Replies



I confirm, we are having the same problem.    


yes we have the same issue
I am also facing the same problem... Just to inform the URL has changed with V2. Which is now -

I am in the UK. We are Office 365 corporate customers and are facing this exact issue as well. Multiple (presuming all) staff. Was OK yesterday.

The same problem here

@BrugianPenguin I'm having the same issue today, was there any fix for this?

I confirm this issue, I also have it.
Tried incognito mode (no cache), different browsers... the problem persists.
Oddly enough my department collegues have no issue pressing "collect answers", and I can't seem to have it working even if it is just a blank questionnaire.

Has anyone found any solution for this?

@BrugianPenguin yes, 
that message was not there yesterday!
even on a V2. it still freezes.
Does #Microsoft have an idea when the issue will be resolved?

This is happening to us too and this is a disaster. Tomorrow is our enrolment day for student classes and our responses are collected with a MS form. This is urgent, is there any workaround where I can get the response link??


EDIT: Seems it does not crash on mobile browsers. I was able to use my phone to get the response link (Chrome browser on Android). If anyone needs to collect answers immediately this should work.


I have the exact same issue - has anyone found a fix for this yet? 

For me as well! any solution yet?

Same here
Not ideal but if you need the link urgently I found it doesn't freeze on mobile browsers (tested with Chrome on Android).
Same issue here with forms
I have the same issue overhere. A colleague of mine too.
Possible solution!!!

I appreciate @Marco_Fernandez tried, but for me Chrome Incognito mode DID allow me to get a link for sharing my Form with others. Still broken in Normal mode.

Chrome Version 104.0.5112.102 (Official Build) (64-bit)
Bah! Spoke too soon. It's now hung, but was offering slightly better odds of getting as far as the link. Will clear my cache etc and see what gives.

@BrugianPenguin Same issue here. 

But it seems to work on Edge for me