SOLVED

Form always shows previous submission

Copper Contributor

I have a user that when they open a form, it always shows their previous submission rather than being blank.

 

I've verified they are looking at the new form URL (responsepage) instead of a previous submissions URL (ResponseDetailPage), but no matter what, it always shows as if they were looking at the previous submission.

 

The form is set to only allow users within the organization, and for multiple submissions.  It works normal for other users, and in my testing I can see both the blank form as well as previous submissions, and switch back and forth between the two with no problems. 

 

We've also tested in an incognito window, clearing cache and cookies, but it always only shows the last submission for him, both of us can be looking at the exact same URL (the responsepage URL for a blank form), and it will be blank for me, but filled in like it was the previous submission details for him.

 

At a loss for this one, anyone have an idea of why it does that for him??

5 Replies
Is this a quiz? After the score is posted, the respondent will only see their previous submission along with their score.
You may try get him to access the form from a different machine to see is it the same behavior? its looks like the browser/registry that keep him viewing previous result.
Not a quiz - it's only this one specific user, all other users can submit without issues multiple times.
We tried different machines, browsers, clearing cache/cookies etc - literally I could go the exact same URL he was and mine was blank whereas his showed a previous response, it was all very odd.

best response confirmed by dlunsford (Copper Contributor)
Solution
After several hours of troubleshooting, we wound up just making a copy of the form and he was able to submit again as normal. We didn't want to have any other users run into the same issue, so just starting over seemed to fix it in this case - frustrating we had to do that, but the form owner was ok with doing it as they had already processed all previous submissions (manual work with the submission details), so moving to a new form wasn't a huge deal.
1 best response

Accepted Solutions
best response confirmed by dlunsford (Copper Contributor)
Solution
After several hours of troubleshooting, we wound up just making a copy of the form and he was able to submit again as normal. We didn't want to have any other users run into the same issue, so just starting over seemed to fix it in this case - frustrating we had to do that, but the form owner was ok with doing it as they had already processed all previous submissions (manual work with the submission details), so moving to a new form wasn't a huge deal.

View solution in original post