Failed to upload your file MS Forms

Copper Contributor



one hour ago i was able to upload files in my form, now i receive the following message: 

failed upload.JPG






Tried different types of files in different browsers, won't help.


43 Replies

... from ms support:

This generally happens when the file location (i.e. OneDrive folder) is either deleted or inaccessible for any reason.

As a workaround, I would suggest to following these steps might help:

Save all responses of your existing Form ABC (example in this case) Create a Copy of the Form ABC (this automatically recreates the OneDrive folder at backend) Step 2 creates a new Form named Form ABC (2) Delete the Form ABC Rename Form ABC (2) as Form ABC Share its new link (the url) and try uploading the file

I tried and it worked for me. Let me know, if this works for you.

That's my post on

Thanks for resharing here
sorry - thought, the answer came from Microsoft Teams-Support.



The problem is not with MS Forms. Of course, the file-upload-questions work, if i share the link. That was never the problem.
But ... If i create an assignment with a "quiz" in MS Teams, members cannot upload files within the upload-questions.
Sharing a link to forms within an assignment in MS Teams makes no sense. Several
teachers in several countries -
in several organisations have the same problem.
Thank you anyway.



We have the same problem here.

As soon as i create the quiz in teams, the form is copied to the sharepoint library of the team. BUT on the upload folder, where the students should upload there files (in the sharepoint library > apps > microsoft form> quiz name > question), the folder is not shared. it happens not all the time, but i would say 80% of the time. as soon as i have some luck and a quiz works, i can see that the folder in sharepoint is shared for uploading files...

we need a resolution...

Did you check the SharePoint permissions for the user who is creating the quiz? This could be one reason.
Another could be the connectivity issue from the user computer to the server being accessed. Possibly the post is not properly getting received at server end.
The user is owner of the Team and i didn't change the permissions in sharepoint. Sometimes it works and sometimes it doesn't....with the same user. So permission problem is not possible. I create the form in forms and as long as i don't try to Import it in Teams as Quiz, it works. I do not upload something....i just import the Form from forms in Teams and both is o365....



so you are lucky ;) ... in my case, it never worked - i checked also the permissions and i tried it in 2 schools with different quiz - aigain and again - now i create my forms, which i need für MS Teams without uploading-file-questions - its a pity. 

there is no answer from the official support too


the problem is in a failed permission-connectivity beetween forms, onedrive and teams.
1) create the form ---> folder in the private onedrive is created - permission only owner
2) make an assignment to a team within the quiz
---> in onedrive-folder: sometimes: permisson for the team is enabled
--> baut upload für students is NOT possible
---> in onedrive-folder: somethimes: no additional permission
----> permission enabled manually
--> upload für students is NOT possible too

The solution (for this one form)

1. Once created the quiz assignment (or programed for the future) in Microsoft teams, you will be able to find copy of the original form in "group forms"(yellow highlighted in the image) in Microsoft forms web page.

2. From there you will need to get in "the form" with the problem and edit it, by eliminating the "file upload questions" and creating them again.

then in works for this form

but a new form in a new team ... sometimes it works - sometimes not
... it is not easy for team-newcomers



Dear Colleagues:

I've create a video to help solving this error. You can access it in

Although it is in Portuguese, you can add the subtitles. Please check if it solves your problem and send me your feedback.
Also you can check other videos in


Best regards
I resolved it please check the video

I resolved it please check the video

@Djarano  I found the solution in this video:


Summary: Go to MS Forms-> Group Forms -> Select Team -> Your Quiz Form -> Delete and regenerate the file upload question.

Hi. I hope you are doing well. I am also having the same problem. I wanted to ask if you managed to upload your documents, if so, please let me know how? Thank you
OMG THANK YOU SO MUCH!!!! u saved my life



Screenshot 2021-11-08 at 08.16.06.png

Had the same issue, wasn't willing to recreate the upload field. TL;DR click on the copy button for the send and collect responses link. It seems to set up the permissions that grant access (as long as they have not been fully removed in sharepoint).


Had the same issue, looks like when an upload field is added a new folder ([SharePoint]/Shared Documents/Apps/Microsoft Forms/[name of form or 'Untitled', will have a 'star' on the right corner of the folder name to denote the folder being new]/[name of question or 'Question'] with a SharePoint group with the handy (but system only generated permission of 'Submit Files').


Then when you land on the form (it controlling access re your sharing preference) it adds the user to both the SharePoint as a user but also too the 'Submits Files' permission group for the folder in question.


The thinking being that some kind of disconnection happens between the form and the SharePoint so a user doesn't get added to the 'Submits Files' permission group. The act of copying the link seems like it might be a trigger for setting that up.


To check if a form upload is still usable right click and manage access on the folder that collects the files then look for the form exclusive sharing link for adding files.

Screenshot 2021-11-08 at 08.23.52.pngScreenshot 2021-11-08 at 08.24.04.png

To see the permission groups continue by clicking advanced, then show users. This will give you a few groups, look for the one with 'Submits Files'. Then click on the name to view. You can't add users to this group but anyone who is listed should be able to use the form correctly. Using the 'Check Permissions' and looking up a user will list what they can do in the folder.

Screenshot 2021-11-08 at 08.25.34.pngScreenshot 2021-11-08 at 08.41.23.png

Good solution.