Export Data from Microsoft Forms Pro

New Contributor

For some reason, when I click "Export all" or checkbox selected rows and click "Export", nothing happens. Specifically, I am trying to export the responses. I had no issues with the export function last week but this week it appears to be a big issue for me. Anyone else having the same issue? I tried using different web browsers and nothing. 

9 Replies
That happened to me a month ago and then it started working on the very next day. I think its a kind of outage from O365 portal itself . Hope this would work , let me know

@kvnwynn I am also having this issue. It's been 2 weeks for me and I still can't export responses from a survey created in Forms Pro.

@Ivanrei After I posted this thread, it started working for couple of days. Thereafter, the 'export' function stopped working. I tried 'exporting' data  2 mins ago and it is still not functioning for me.


I believe this sporadic issue has a bigger underlying issue that only Microsoft 365 can resolve. 

I am also having the same problem.



Me too.  Still no action from Micro$oft... shambolic attitude towards customer service.

@kvnwynn Current workaround per microsoft: 

"We know of some intermittent issues with export. This should be fixed this week. In the meantime, you can try to get access to the responses in excel by using - https://forms.office.com/Pages/RedirectToExcelPage.aspx?id={form_id}&forceReExport=true

replace {form_id} with the form id"

Is the Microsoft Forms Pro Preview Export feature still broken?


I don't see an Export to Excel when I look at my Question Responses.  The URL still works, but it would be nice to not have to refer back to this question every time.

@MattHong I believe it is now working, I haven't tested it super recently but I know shortly after I posted this they did in fact repair it. 

One thing to note is in the Responses tab, you do need to click on the number of responses to be able to access the export to excel button.

Thanks @Ericvde.  I see the Export button now.  I'll have to play with it a bit more, but my responses in the Excel export are being cut off in the long answer format that wasn't happening with the URL.