Error when attempting to add a Form to an Excel workbook

Occasional Contributor

We have a user that is receiving the following error:


"You don't have permission to add a Form to this shared workbook.
Create your own Excel workbook and try again."


This happens when the user creates their own Excel workbook in a SharePoint site that they own/administer. They are opening the workbook in the Excel web app and choosing Insert >> Forms >> New Form

It's occurring with every Excel workbook.


They have shared the file with me and I am experiencing the same error. It's not happening on files I create, though.


Does anyone have any insight into this error?

EDIT: This is reproducible 100% of the time when attempting the above steps from a new SharePoint document library. The existing (default) library does not seem to be affected.
15 Replies

@lrc5333 We having the same issue, we have made sure document is checked in etc.
Made sure all mandatory properties are filled in.
Tried with both member and owner permissions.

Any help appreciated.

Hello, TheJakes,

We are still experiencing this issue. I have raised a ticket with Microsoft Support, but have yet to find a solution. I am in the process of having the affected user try different document libraries and different permission settings in SharePoint to see if anything changes. I will update this post if I find a resolution.

Same issue here. Guess it could be global?

@mgudites1@lrc5333 I, too, am having this issue. We were able to create forms from SharePoint a week ago just fine, but now it doesn't seem like it's working on any of our sites and we get the same error: "You don't have permission to add a Form to this shared workbook. Create your own Excel workbook and try again." However, I can create a Form from SharePoint in the default document library (the document library that exists when the site is created, and can't be deleted by default). Is this the case for you too?

@gtew234 Good find! I just confirmed that the default document library causes no issues. However, I just created a new document library in a site I own and was able to replicate the problem. I wonder if something is breaking folder inheritance.

@lrc5333 Hmm, this may well be a global level issue. Maybe they're working on the Forms file upload functionality to expand it to external form respondents as well, and they broke something? But I'm just spitballing here.

I don't know if this helps but I was also able to go directly to and create a shared group form for the group in question. Doesn't solve the problem of wanting to have the document placed within the doc library but, for now it's a workaround here. I just put URL shortcuts into the doc library so the team could easily access the form and the 'results' page.

Hi, any feedback you have received on this? I hope a ticket was already submitted for this.

@GriefbladeNothing concrete yet. I have shared this thread with Microsoft.

@lrc5333 We have the same problem also



best response confirmed by lrc5333 (Occasional Contributor)

@RespectandPeace @Griefblade @mgudites1 @gtew234 @TheJakes 


Microsoft got back to me with a fix that resolved this issue for our tenant. In the Office 365 admin center, navigate to Settings >> Services & add-ins >> Microsoft Forms. Toggle On the "Share form result summary" option if it's off (we have every option in here enabled).

@lrc5333 It was already ticked for us, but the problem is now resolved, so i suspect something changed to untick, and MS have now rectified. 

@lrc5333 It's May and I'm still seeing this problem.

All the options under the Office 365 Admin for Forms are checked.

@Luke Chung You're better off starting a new thread or reaching out to Microsoft. The issue has not returned for our tenant.

I think this bug is related to the O365 Group linked to the SharePoint Team Site @lrc5333 

After some testing we found out that if you are not a member of the O365 Group Linked to the SharePoint site or if the O365 linked Group permissions were removed from the site this error shows up 

I think this happens because MS forms tries to login to SharePoint using the Linked O365 Group and not the actual account,

So if the Group doesn't have access to the Library, then it will error out, 

We still need to do some more testing to prove this theory, but so far, when we re-add the user to the o365 group or we give permission to the O365 group back to the library, it works again