Collect form responses from "specific people in my organization" question

%3CLINGO-SUB%20id%3D%22lingo-sub-2007657%22%20slang%3D%22en-US%22%3ECollect%20form%20responses%20from%20%22specific%20people%20in%20my%20organization%22%20question%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2007657%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20recently-added%20functionality%20has%20huge%20implications%20for%20our%20University.%20We%20have%20a%20fair%20number%20of%20forms%20which%20should%20only%20be%20available%20to%20%22faculty%22%20or%20%22students%22%2C%20and%20we%20have%20Active%20Directory%20(local%20server%2C%20synced%20to%20AAD)%20groups%20for%20those%20audiences.%20However%2C%20it%20doesn't%20appear%20that%20we%20can%20share%20a%20form%20to%20an%20AD%20or%20AAD%20security%20group.%20Individual%20users%20and%20M365%20groups%20resolve%2C%20but%20not%20AD%2FAAD%20groups.%20Is%20this%20by%20design%2C%20or%20an%20unintentional%20limitation%3F%20I%20know%20-%20in%20general%20-%20Microsoft%20seems%20to%20be%20pushing%20organizations%20toward%20using%20M365%20groups%20in%20place%20of%20AD%20groups%2C%20it's%20just%20not%20a%20viable%20option%20for%20many%20of%20us.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2007657%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EForms%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Forms%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2008291%22%20slang%3D%22en-US%22%3ERe%3A%20Collect%20form%20responses%20from%20%22specific%20people%20in%20my%20organization%22%20question%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2008291%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F86417%22%20target%3D%22_blank%22%3E%40ChadKealey%3C%2FA%3E%26nbsp%3Bthanks!%26nbsp%3B%20You%20found%20a%20new%20bug.%26nbsp%3B%20Developers%20just%20looked%20into%20it%20after%20you%20posted%20and%20groups%20with%20Mail-Enabled%20off%20are%20getting%20filtered%20out.%26nbsp%3B%20We%20will%20fix%20this.%26nbsp%3B%20Expect%20the%20fix%20to%20land%20early%20next%20year%2C%20and%20then%20you%20can%20try%20again.%26nbsp%3B%20Thanks%20again!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Regular Contributor

This recently-added functionality has huge implications for our University. We have a fair number of forms which should only be available to "faculty" or "students", and we have Active Directory (local server, synced to AAD) groups for those audiences. However, it doesn't appear that we can share a form to an AD or AAD security group. Individual users and M365 groups resolve, but not AD/AAD groups. Is this by design, or an unintentional limitation? I know - in general - Microsoft seems to be pushing organizations toward using M365 groups in place of AD groups, it's just not a viable option for many of us. 

9 Replies

@Chad_V_Kealey thanks!  You found a new bug.  Developers just looked into it after you posted and groups with Mail-Enabled off are getting filtered out.  We will fix this.  Expect the fix to land early next year, and then you can try again.  Thanks again!

@Jon_Kay & @Kathy Myers , I just checked this and it seems to be accepting AD/AAD (non-mail enabled) security groups now. There's still a limit of 1,000 recipients/group members, though, which is a bummer. But, this is better than it was.

@Chad_V_Kealey You're right. I just didn't wait patiently long enough for the sync. Sorry.:flushed:

I am trying to set specific people in my org to be able to respond to a form but nothing gets resolved. No users or groups, the "Searching" spinner just keeps spinning and never stops.
Any idea why? My form was created in a Teams channel and is a group form. No one in the group can add a response. The input boxes don't allow input except to me in preview mode.

@PamJustice , it's working as intended for me. What web browser are you using and have you tried another? I typically use Edge, but also tested in Chrome and it's working fine in both.

@Chad_V_Kealey  I'm using Teams desktop but I have also tried in Edge and Chrome but get the same action.  The "Searching" for a person just spins and never errors out or finds anyone.  Using is Forms is new to my tenant since it wasn't available to GCC clients until this June.  I've checked to make sure everything in Teams Admin is configured correctly as well as in AAD Enterprise applications.  Forms is enabled for everyone in my organization and is also enabled in Teams Admin Center Apps.  No policy that I know of is blocking it.

I would suggest opening a support ticket. We're an EDU tenant (which has its own quirks), so I'm not familiar with the ins & outs of GCC tenants. Do you know if other users in your tenant are having the same problem? It seems more likely to be a tenant issue than a specific user problem.
@Chad_V_Kealey
I was hoping to avoid MS support. The endless requests for log files is getting on my nerves. Anyway, it seems to be working now. I was able to get past the spinnng "Searching" and assign access to specific people in my tenant. I was told that our systems staff is cleaning up our security groups so that may have had something to do with Forms suddenly syncing our users. They get reindexed every so often, right? It's working so thank you for your suggestions.