Can't see some of my Groups on Forms

Brass Contributor

OK .. so I love forms ... and I use it for a lot of things. But I'm having trouble figuring out the criteria for why a group shows up in my Group Forms listing or not.


I thought it was a group ownership issue as opposed to group members... but there are many groups that I own that aren't showing up in my list.


Any ideas out there in Forms land??

18 Replies

This is also something I am trying to figure out. There doesn't seem to be any reason why some Groups appear as either a destination to move an existing form to or to appear in the Groups tab.


I have created new test Groups in different ways (Private vs Public, via the Admin portal and through Teams) and still can't get them to show up. However, a Group i created a month ago via the same methods appears.


Any help from the community would also be appreciated!



Hi @CYappert 


From my experiences, once the group has ownership of the Form, it appears in the Group forms tab. From there I can pop down the Recent group forms list and view all my groups. I would then select a group and the form/s within it.




Don't use the search bar to the right of the page as it will not show group form results unless you have selected a specific group to search within.


Hope that helps?




Well, the issue is that it's not possible to give ownership to a group if the group does not show up in any list or view. ... And that is my actual problem .. not all groups/teams are showing up



So an update on this ... MIcrosoft says it's because indexing on grps is not finding the other grps that I'm a member of .. that essentially the grps are non-searchable and so are not showing up. 


Unfortunately, when they ran an index .. it didn't work. So still at square one.

I figured out my issue. Turns out I was only an owner in some of my Groups and not a member. Adding myself as a member allowed me to see these in Forms and my issue was resolved. @CYappert 

@Brian_Stauber This worked for me!


I went into the Teams Admin Center and noticed I was not in the Team, even though I created the team and was listed as an owner in Teams.  I added my user account with my admin account and the team showed up in the list!


Thanks Brian! +1   

@Chris Smith 


OK so a bit of an update ...


We've been working on this with Microsoft for a few months now .. and even they don't know what the issue is. We have tried all kinds of approaches. 

Our challenge is that the groups that are not showing up are dynamically generated based on PowerShell scripts on AD so it's not just a matter of adding a person to a TEam if they aren't part of the department that is being automatically maintained.


Microsoft has now recognized that this is a bug for auto-generated teams/groups and has suggested that if we moved away from automated it would just work .. not going to happen.


So We wait till MS fixes it. Or provides us better Teams tools to maintain team membership programmatically.

I have the same problem.
How can I see all teams in groups forms?
try adding yourself as a member of all the teams.

@Chris Smith worked for me also, adding as a member! Thank you! :)

@Chris Smith @Brian_Stauber Adding myself as a group member (and not just an owner) worked for me! I had to add through Office365 Admin portal and not in the Teams Dashboard. THANK YOU!!!!

@Chris Smith Thank you! This has been bugging me for months!!! So strange that you can be an owner but if not a member in the admin centre doesn't show up in Forms! 

I found the site has to be a Teams site not a Communication site. 

Many thanks Brian, been looking for this for a while. Still feels like a bit of a workaround, but works a treat.
Totally fixed this, thank you!!!

@Brian_Stauber amazing Pro, it's really works :)

thnx alot for sharing :X

Thank you so much! it works. I Created 3 groups, 2 shows up in form, 1 doesn't. so I added myself as memeber , it shows up.