AAD Seamless Single Sign-On and Chrome

Occasional Contributor



I have deployed AAD Seamless SSO recently and it all works just fine in Edge / IE. However I cannot get the SSO experience to work with Chome. 

I have checked the GPO settings mentioned in Microsofts Documentation.


Anyone that knows if there is a problem with the service and Chome at the current version?

7 Replies

@Marcus Pettersson Did you ever get this working? I am having the same issues.

@Rocketrs8 are you using AAD Seamless SSO with PTA or PHS?

@Dominik Hoefling I am using Seamless SSO with PTA. I downloaded the Chrome ADMX files and configured Kerberos delegation server whitelist and Authentication server white list adding autologon.microsoftazuread-sso.com to both. 

Thanks. Did you check the troubleshooting page as well? https://docs.microsoft.com/en-us/azure/active-directory/hybrid/tshoot-connect-sso


I haven't any problems with PTA and AAD Seamless SSO (I'm using Chrome for Windows Version 75.0.3770.142). I would suggest to run Fiddler and verify if the browser get the 401 unauthorized response from Azure AD, to provide a Kerberos ticket.


I assume that modern authentication is enabled in Exchange Online (this is a prerequisite).

@Dominik Hoefling I didn't have modern authentication turned on however I did that last night. Still not any better. I have looked through that documentation and nothing jumps out. Also, it is quite out dated with certain things. One "big" thing is that Edge doesn't work when actually now it does. 


I think Fiddler is a good call. I will give that a bash

@Rocketrs8We are currently encountering the same issue in the chrome browser. Could you please share the information on, how you fixed it?

@Marcus Pettersson 


If I am not mistaken, you need to install the Windows 10 Accounts extension for Chrome for Seamless SSO to function.