SOLVED

Deploying D4IoT Sensor to ThinkEdge SE40 - No Root Filesystem

Occasional Contributor

Hi all,

 

I'm in the process of setting up a POC with D4IoT to showcase to our partners. 

Unfortunately I've been having trouble installing directly on a Thinkedge SE40.

When trying to install (100 GB profile) it seems like it fails on autocreating the partitions for the system and I'm getting an error displaying "No Root Filesystem". To my understanding there shouldn't be a problem installing on various hardware profiles?

 

I’ve tried the following without luck:

  • Delete partitions completely
  • Create an ext4 partition over 100 GB (112GB) – rest as swap.
  • Create an ext4 partition on 100 GB – rest as swap.
  • Try and install 60 GB & 8 GB profile and even trying larger versions.

 

I have no problem installing a normal ubuntu server on the hardware.

I’ve attached an install log and picture of fault.

 

I have no problem installing it in a VM - everything works there.

So another solution i tried was to backup the VM and load it on the hardware.

I was hoping i could run:

 

sudo cyberx-management-network-reconfigure

That doesn't seem to be available on the sensor host though. 

So I tried changing it manually in netplan, which brings the device on the network. 

But when trying to load the webinterface it's just spinning with "Collecting Data" indefinitely. 

 

I think it's a shame if i'm forced to install proxmox or another hypervisor on the hardware just to run it as a VM.

 

Hardware Specs:

ThinkEdge SE40

Core i5 8365UE / 1.6 GHz - RAM 8 GB - SSD 128 GB

 

Hope somebody can help me move on.

 

Best Regards,

Jesper Hauge Rasmussen

9 Replies
Hi
Please elaborate on what are you trying to install and which documentation are you using for the installation. based on your reply we can assist better.
OT: https://docs.microsoft.com/en-us/azure/defender-for-iot/organizations/getting-started
eIoT: https://docs.microsoft.com/en-us/azure/defender-for-iot/organizations/tutorial-getting-started-eiot-...

Hi @AdiWeisberg,

 

Thank you for your reply.

I'm trying to install the OT Sensor to a ThinkEdge SE40 with these instructions: https://docs.microsoft.com/en-us/azure/defender-for-iot/organizations/how-to-install-software?tabs=s...

 

I've attached log from failed installation as well. 

 

Thanks. no need to run CLI commands or change partition during the installation, but following the step-by-step instructions in the docs. Are you using "office" architecture on step 2?
(Maximum monitoring bandwidth 100 Mb/sec
Maximum monitored assets 800
CPU 4
Memory 8 GB
Storage 100 GB (150 IOPS)

Hi @AdiWeisberg,

 

Yes and I also tried the smaller architectures and even the bigger ones.

It works fine when I install it in a VM.

Are you using USB or portable DVD for the installation? I suggest using a portable DVD. and starting over per the defined steps. you can raise a technical support ticket via the azure portal in case your installation keeps failing. support will help with the troubleshooting.
Ok, I'll raise a technical support ticket in Azure Portal.

@jehara please also make sure Bios is in LEGACY and not EUFI

Hi Adi,
Thank you for your suggestion.
It's not even possible to boot the installation media if it's in UEFI - So that was the first few lessons I learned. But unfortunately that's not the issue here.
best response confirmed by jehara (Occasional Contributor)
Solution

In case somebody else runs in to this problem I managed to find a solution in the end.

Basically, the problem is that when you boot from the installation USB media, it names the installation media sda and the internal harddrive sdb in /dev. This properly wouldn’t be the case if you installed from an optical media like @AdiWeisberg suggested – but I didn't have access to one and I must admit it's a decade since i've used an optical disk for installation.

So the seed files for autopartitioning only looks for sda and not sdb.
So, by changing line 6 in the seed file corresponding to the solution you want to install (in my case the 100 GB solution, named: preseed/laptop-storage-layout.seed) from /dev/sda to /dev/sdb it installs fine.

 

Edit:

Line 107 in preseed/general.seed should be corrected from /dev/sda to /dev/sdb as well. Else it will install the bootsector on the installation media instead of the installation drive. So when you remove the installation media it won't boot as i just figured out ;)

Hope this can help somebody else.