Installing on Server Core

New Contributor

I've tried every combination I can think of and find with the "/?" help and cannot get the Azure ATP Sensor to install on any of my Server Core (2016 or 2012R2) Domain Controllers. Any hints?


Whether I run using /quiet or not the installer process starts for about a second then dies.

18 Replies



Can you (privately) share the deployment logs from this failing machine?


There are 3 log files for the deployment

Azure Advanced Threat Protection Sensor_$(timestamp).log

Azure Advanced Threat Protection Sensor_$(timestamp)_000_MsiPackage.log



Logs will located at the users temp directory or C:\Windows\Temp


Plus, if it's urgent, I strongly suggest to open a support case.


Sure but I can't figure out how to share files privately?

Hello Ray, 

this command installed the Sensor on my Server 2016 Core.

"Azure ATP Sensor Setup.exe" /q NetFrameworkCommandLineArguments="q" AccessKey=****************


I'm also running into issues with the installation of the sensor on a core DC. Tried it with the suggested command but no luck. Which .NET framework version is required? Got 460805 (4.7).

4.7 to 4.7.2 should work fine.

okay - still no luck. starting the installer with the suggested commands and the installer just appears for some seconds. where are the logs stored?

I am seeing the same issue.  Per the logs it is an issue with a proxy.  Since Windows Core doesn't have Internet Explorer installed on it, I am wondering if it isn't seeing the Proxy settings and thus is failing. 

  1. LaunchNotepad with elevated permissions
  2. Open "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config"
  3. Add the following text just above the </Configuration> tag at the bottom of the document:
    ​    <>
            <defaultProxy enabled="true" useDefaultCredentials="true">
  4. Save the config file and restart the computer

@Klaus Reiter 

Hi Klaus following your suggestion I've tried from a command prompt on the server core to run the Azure ATP Sensor Setup.exe but still return the error

'"Azure ATP Sensor Setup.exe"' is not recognized as an internal or external command,
operable program or batch file.


Any ideas?

Thanks a lot


@ilmauri , This error usually indicated a file damaged during download. can you try with a fresh one?

If it still happens, can you share its version from the details tab, its size, and if you can the file's hash?


@Eli Ofek 

Hi Eli

yes you are right, redo the download from Atp portal and setup works fine


Thank you


this worked for us. thank you.

Hi - Has anyone successfully installed the Azure ATP sensor on Server 2012 R2 Core? I wasn't sure if this was supported.

I would assume it would be. It takes a awhile. The event viewer is good place to monitor if there is a issue. But it took a lot longer than I thought it should.

@Steven Hoggatt Thank you for your insight! I'll take a look at the Event Viewer to see what I can find.

@Klaus Reiter I have downloaded the Azure ATP Sensor to my share location \\server\atp sensor

so how do i install from server core?


"Azure ATP Sensor Setup.exe" /q NetFrameworkCommandLineArguments="q" AccessKey=****************

@AusSupport180 just like that.
"Azure ATP Sensor Setup.exe" /q NetFrameworkCommandLineArguments="q" AccessKey=****************


I copied the sensors to the c:\temp folder for each DC but I don't see why you couldn't run it from a UNC path.