build 2.116.8140 ssl/tls failure when starting

%3CLINGO-SUB%20id%3D%22lingo-sub-1468606%22%20slang%3D%22en-US%22%3Ebuild%202.116.8140%20ssl%2Ftls%20failure%20when%20starting%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1468606%22%20slang%3D%22en-US%22%3E%3CP%3EHI%20%2C%3C%2FP%3E%3CP%3ESince%20build%202.116%20we%20have%20some%20sensor%20on%20DC%20randomly%20having%20starting%20error%20.%3C%2FP%3E%3CP%3EThey%20all%20have%20this%20error%20in%20the%20tri.sensor-error.log%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESystem.Net.WebException%3A%20The%20request%20was%20aborted%3A%20Could%20not%20create%20SSL%2FTLS%20secure%20channel.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOur%20guest%20it%20linked%20to%20update%20error%26nbsp%3B%3C%2FP%3E%3CP%3E2020-06-16%2015%3A53%3A58.0813%20Debug%20SensorUpdaterService%20OnStart%20started%3CBR%20%2F%3E2020-06-16%2015%3A53%3A58.0969%20Info%20SoftwareUpdater%20DeleteOldVersionDirectories%20%5BdirectoryInfos%3D%5D%3CBR%20%2F%3E2020-06-16%2015%3A53%3A58.1282%20Info%20SoftwareUpdater%20DeleteOldVersionLogs%20%5BdirectoryInfos%3D%5D%3CBR%20%2F%3E2020-06-16%2015%3A54%3A02.9408%20Warn%20ClientCertificateAuthenticationMiddleware%2BClientCertificateAuthenticationHandler%20AuthenticateCoreAsync%20%3CFONT%20color%3D%22%23FF0000%22%3Emissing%20client%20certificate%3C%2FFONT%3E%3CBR%20%2F%3E2020-06-16%2015%3A54%3A02.9720%20Warn%20AppBuilderExtension%20UseExceptionHandler%20IOException%20ignored%20%5BDetails%3DInnerExceptionType%3DHttpListenerException%20ErrorCode%3D1229%5D%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20re-install%202.116%20just%20fine%20%2C%20but%20failed%20starting%20after%20initial%20syncy%3C%2FP%3E%3CP%3EI%20can%20push%20config%20from%20console%20%2C%20syncing%20process%20seem%20to%20be%20working%20fine%20but%20failed%20at%20restart%20after%3C%2FP%3E%3CP%3EI%20can%20re-install%202.115%20and%20watch%20update%20process%20working%20fine%20but%20failed%20a%202.116%20restart%3C%2FP%3E%3CP%3EThey%20all%20using%20the%20same%20proxy%20configuration%20.%3C%2FP%3E%3CP%3EI%20am%20having%20other%20DC%20in%20the%20same%20domain%20working%20perfectly%3C%2FP%3E%3CP%3EIt%20look%20like%20iam%20having%20a%20%22atp%20client%20certificate%22%20in%20the%20store%20but%20ill%20be%20comparing%20certificate%20with%20working%20DC%20%2C%20see%20if%20i%20did%20not%20miss%20another%20one.%3CBR%20%2F%3E%3CBR%20%2F%3EWe%20already%20have%20a%20open%20ticket%20at%20MS%20.%3C%2FP%3E%3CP%3EBut%20i%20am%20taking%20chance%20here%20too%20%2C%20see%20if%20i%20anyone%20have%20idea%20on%20the%20certificate%20error%20%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

HI ,

Since build 2.116 we have some sensor on DC randomly having starting error .

They all have this error in the tri.sensor-error.log

 

System.Net.WebException: The request was aborted: Could not create SSL/TLS secure channel.

 

Our guest it linked to update error 

2020-06-16 15:53:58.0813 Debug SensorUpdaterService OnStart started
2020-06-16 15:53:58.0969 Info SoftwareUpdater DeleteOldVersionDirectories [directoryInfos=]
2020-06-16 15:53:58.1282 Info SoftwareUpdater DeleteOldVersionLogs [directoryInfos=]
2020-06-16 15:54:02.9408 Warn ClientCertificateAuthenticationMiddleware+ClientCertificateAuthenticationHandler AuthenticateCoreAsync missing client certificate
2020-06-16 15:54:02.9720 Warn AppBuilderExtension UseExceptionHandler IOException ignored [Details=InnerExceptionType=HttpListenerException ErrorCode=1229]

 

I can re-install 2.116 just fine , but failed starting after initial syncy

I can push config from console , syncing process seem to be working fine but failed at restart after

I can re-install 2.115 and watch update process working fine but failed a 2.116 restart

They all using the same proxy configuration .

I am having other DC in the same domain working perfectly

It look like iam having a "atp client certificate" in the store but ill be comparing certificate with working DC , see if i did not miss another one.

We already have a open ticket at MS .

But i am taking chance here too , see if i anyone have idea on the certificate error ?

 

 

0 Replies