Issues installing MDE on Win2K12 R2

%3CLINGO-SUB%20id%3D%22lingo-sub-3056349%22%20slang%3D%22en-US%22%3EIssues%20installing%20MDE%20on%20Win2K12%20R2%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3056349%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%20I've%20been%20able%20to%20install%20MDE%20on%20Win2K16%20%26amp%3B%20Win2K19%20however%2C%20Win2K12%20R2%20is%20proving%20to%20be%20abit%20more%20complicated.%20When%20I%20execute%20the%20onboarding%20package%20I%20get%20the%20following%20error%3CBR%20%2F%3E%3CBR%20%2F%3E%5BError%20Id%3A%2015%2C%20Error%20Level%3A%201%5D%20Unable%20to%20start%20Microsoft%20Defender%20for%20Endpoint%20Service.%3CSTRONG%3E%20Error%20message%3A%20The%20service%20name%20is%20invalid.%3C%2FSTRONG%3E%3CBR%20%2F%3EFor%20more%20information%2C%20visit%3A%20%3CA%20href%3D%22https%3A%2F%2Fgo.microsoft.com%2Ffwlink%2Fp%2F%3Flinkid%3D822807%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgo.microsoft.com%2Ffwlink%2Fp%2F%3Flinkid%3D822807%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWent%20to%20the%20link%20and%20couldn't%20resolve%20the%20issue.%20I%20also%20noticed%20that%20Powershell%20is%20missing%20the%20Defender%20Module.%20Are%20there%20pre-requisites%20that%20are%20required%20before%20I%20can%20install%20MDE%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hello, I've been able to install MDE on Win2K16 & Win2K19 however, Win2K12 R2 is proving to be abit more complicated. When I execute the onboarding package I get the following error

[Error Id: 15, Error Level: 1] Unable to start Microsoft Defender for Endpoint Service. Error message: The service name is invalid.
For more information, visit: https://go.microsoft.com/fwlink/p/?linkid=822807

 

Went to the link and couldn't resolve the issue. I also noticed that Powershell is missing the Defender Module. Are there pre-requisites that are required before I can install MDE?

3 Replies
did you install using the install.ps1 helper script or just manually installed the package? the install.ps1 helper script will check for any missing pre-reqs (https://github.com/microsoft/mdefordownlevelserver) . I have also found that occasionally even when the install reported successfully that either the PowerShell module was missing or the MDE engine version was blank. Running UpdatePlatform.exe (https://go.microsoft.com/fwlink/?linkid=870379&arch=x64) to update the defender engine and mpan-fe.exe (https://www.microsoft.com/security/encyclopedia/adlpackages.aspx?arch=x64)) resolved these issues on server 2012 R2 running the Unified MDE client.

If this doesn't work I would raise a support case with Microsoft for the issue.

hope that helps

Steve:)
Secondly, I run the MDE Client Analyzer. Test: OMSListener; Resulta: SenseOms listener missing;
Guidance: This device is unable to upload cyber data. Contact Microsoft support if issue persists and you require assistance with onboarding.

I performed a telenet on the server to see if I can get out and it responds
If the Defender PowerShell module is missing (e.g. Get-MPComputerStatus etc) does not return data or errors this needs to be resolved first as a lot of the other tools you run to collect MDE data rely on the PS cmdlets.

Also since there is no GUI on Server 2012 R2 you also need to use the PS cmdlets for running AV scans [Start-MpScan -ScanType QuickScan]