SOLVED

MCAS not detecting new SharePoint sites/libraries

%3CLINGO-SUB%20id%3D%22lingo-sub-1119882%22%20slang%3D%22en-US%22%3ERe%3A%20MCAS%20not%20detecting%20new%20SharePoint%20sites%2Flibraries%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1119882%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F376955%22%20target%3D%22_blank%22%3E%40cloud_entropy%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EDid%20you%20try%20to%20type%20the%20library%20name%20in%20the%20settings%20folder%20location%20or%20you%20haven't%20found%20it%20in%20the%20presented%20list%3F%3C%2FP%3E%0A%3CP%3EAdding%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F76512%22%20target%3D%22_blank%22%3E%40Dima%20Donhin%3C%2FA%3E%26nbsp%3Bto%20this%20thread.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EBest%2C%3C%2FP%3E%0A%3CP%3EBoris%20K%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1120193%22%20slang%3D%22en-US%22%3ERe%3A%20MCAS%20not%20detecting%20new%20SharePoint%20sites%2Flibraries%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1120193%22%20slang%3D%22en-US%22%3EYes%2C%20tried%20this%20as%20well%20-%20unfortunately%20no%20success...%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1122247%22%20slang%3D%22en-US%22%3ERe%3A%20MCAS%20not%20detecting%20new%20SharePoint%20sites%2Flibraries%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1122247%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F376955%22%20target%3D%22_blank%22%3E%40cloud_entropy%3C%2FA%3E%20%2C%3C%2FP%3E%0A%3CP%3EMCAS%20detects%20new%20folders%20only%20after%20some%20file%20activity%20has%20been%20performed%20in%20them.%3C%2FP%3E%0A%3CP%3EI%20suggest%20you%20upload%20a%20single%20file%20to%20the%20new%20folder%2C%20which%20will%20cause%20MCAS%20to%20pick%20it%20up.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ERegards%2C%3C%2FP%3E%0A%3CP%3EDima%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1119595%22%20slang%3D%22en-US%22%3EMCAS%20not%20detecting%20new%20SharePoint%20sites%2Flibraries%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1119595%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20currently%20in%20a%20test%20phase%20of%20implementing%20MCAS.%20Main%20use%20case%20will%20be%20session%20and%20file%20policies%20for%20OneDrive%20%2F%20SPO.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20have%20also%20configured%20a%20specific%20SharePoint%20document%20library%20to%20be%20used%20for%20quarantine.%20But%20in%20the%20settings%20menu%2C%20it%20does%20not%20show%20up%20in%20the%20list%20of%20available%20folders.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20does%20also%20not%20show%20up%20in%20the%20investigate%2Ffile%20queries.%20Does%20MCAS%20require%20certain%20permissions%20on%20the%20SharePoint%20sites%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESomeone%20else%20has%20issues%20that%20SP%20libraries%20not%20showing%20up%20in%20MCAS%3F%20(We%20have%20waited%2024%20hours%20now%2C%20still%20not%20visible%2Favailable)%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1119595%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EApp%20Connectors%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ECloud%20App%20Security%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Contributor

We are currently in a test phase of implementing MCAS. Main use case will be session and file policies for OneDrive / SPO.

 

We have also configured a specific SharePoint document library to be used for quarantine. But in the settings menu, it does not show up in the list of available folders.

 

It does also not show up in the investigate/file queries. Does MCAS require certain permissions on the SharePoint sites?

 

Someone else has issues that SP libraries not showing up in MCAS? (We have waited 24 hours now, still not visible/available)

4 Replies

Hi @cloud_entropy 

 

Did you try to type the library name in the settings folder location or you haven't found it in the presented list?

Adding @Dima Donhin to this thread.

 

Best,

Boris K

Yes, tried this as well - unfortunately no success...
best response confirmed by cloud_entropy (Occasional Contributor)
Solution

Hi@cloud_entropy ,

MCAS detects new folders only after some file activity has been performed in them.

I suggest you upload a single file to the new folder, which will cause MCAS to pick it up.

 

Regards,

Dima

Thanks, this worked actually!