This link is not valid. for Bookings

Copper Contributor

I use the web version for bookwithme and was working fine past few weeks but suddently doesn't work anymore with the following message after the link is shared by copying the link or sent via email:


This link is not valid.
Please contact the organizer to check if the URL is correct.
52 Replies
I'm having the same issue.
I have the same issue but only with Private meetings. Public links just work fine. I tried to create new Private meetings, and creating a Public one and making it Private. In both cases the link fails.
Something that confirms that the issue is related with Private meetings/links: I made a Private meeting and then made it Public: that worked OK. As I said before, in my experience this only happens with Private meetings and their links.
Experiencing the same issue. Public links work, private ones don't.

Same issue here, public still works, private stopped working this week after running without any issues for many month. Any solution?

Same issue, no private links are working

@SallyPgy I've just discovered the same issue. With no warning about this private/ public change, it makes me nervous to keep using Bookings. Please stop breaking things, Microsoft! We pay for service because we want it to work!

Same here. Private does not work for me and several other members of our team, but public does. Microsoft, STOP PUSHING CODE THAT DOESN'T WORK
I am having this issue too. Has their been a solution?

@SallyPgy Same issue here with only private links. Public works fine. 

Confirmed the same scenario in my org today. Public mtg links work, Private mtg links fail.
Same issue here, we have worked around by moving private events to public and sharing that public link in the meantime, but this removes the ability to share a one time link

Confirmed same issue, private links give an error while the public links still working

Same issue here as well...

@PabloEVarisco exactly same behavior as yours. Thanks for sharing. 


First time using Bookings though, so will try with public link first. 

Same issue happening to all the users in my organization, neither multi-use nor single-use private links work, just public.

Same issue here as well. Changing events to Public is our workaround as well.
Yup Same here.. Just had people complaining all their private links have expired and not working.. This makes it very difficult when you want to publish the same links year on year for staff :\

same here

Same problem - resolved temporarily by recreating a public link (but not a good solution). Please fix Microsoft.