Microsoft Bookings - opening a new calendar

Copper Contributor

I have one active Bookings calendar and wanted to add a second calendar for a second location.  I was able to create the calendar when I clicked on New.  However, now when I click on Open, I am prompted to Choose a Calendar and the one I just created is not an option.  It says + Add a Booking Calendar and then just has me enter new business information.


How can I access more than one bookings calendar from my account?



8 Replies



I'm also having the same issue, have you able to find a solution?

Also when I tried to open up my booking calendar on mobile app, it can't find the calendar, I can only create new calendar on mobile.



Unfortunately we still don't have a solution and is really the primary issue we have with Bookings.  For now we have just consolidated our calendars into one. I have had the same issue on the mobile app.  @Ngardi 

Thanks @JNagiel 

I'll let you know if I find something.


I've just found a workaround for this. When you setup a new booking calendar it will automatically generate an email address with your organization domain. Also you can find this email address at the bottom of confirmation email that you received with the new calendar creation.


You can keep list of those email address and use the following link to access any calendar.<email address for the booking calendar>


Hope this help. @JNagiel 

I will give that a try!  Thanks! @Ngardi 

@JNagiel Did the hyperlink solution work for you? Unfortunately for me it still says I don't have access even though I was the original creator. I really regret making a second calendar because I didn't know it would delete my first one. 

@jsheridan355 Check if you have full access permissions to the mailbox that was created part of the calendar. You will have to check it in Office 365 admin center.



I know this is an old post, I worked out the best way was to add a password the booking account in Office 365, then using private browsing log in with that account.

The url posted help me get so far, but as the email address doesn't have a mailbox it was not possible to add any permissions.