Homepage redirect to onboarding page stuck in loop

Copper Contributor

This is happening to two of our 8 team members. When they try to log on to Bookings the get stuck in an endless auto reload loop between the homepage and onboarding. It tries to reload to the opposite page every few seconds. We have updated browsers, tried different browsers, Mac and PC, cleared cookies, incognito, everything we can think of. They are loaded in Bookings the exact way the other 6 team members are. 

21 Replies
@ekles402 can you please confirm:
- Did this happening recently? Was there access working before?
- Do these users have a valid Bookings license?
- Did they get removed from any Booking page recently or a booking page they were managing was recently deleted?
- Are they able to load the app if they go directly to https://outlook.office.com/bookings/calendar?calendar=smtp_of_their_booking_mailbox@tenant.onmicroso... (please replace the parameter value with the SMTP address of the booking page that you can get from its URL)

If the issues persist, can you please raise a support ticket with a network trace from the browser so that we can debug this further?



I am experiencing the same issue. 


This is the first time that I have tried to access booking as our company has only just started using it. Other members of the team face no issues. 

To my understanding, nothing has been deleted recently. 


Even if I try to click anything on the pages it is cyscling through, nothing happens. 


Any help would be much appreciated. 


It happened last week, it was the users first time trying to access the system. 

We all have a valid license/permissions through our company  

After the issue happened we removed them from the page and readded them to try and solve the issue but it did not work. 

I will have them try your url

@ekles402 I have the exact same problem.

I try to use Bookings for the first time and it loops between https://outlook.office.com/bookings/onboarding and https://outlook.office.com/bookings/homepage.


I cannot do any action.

Tried on Chrome, Safari

The page https://outlook.office.com/bookwithme/me I get an error.


Booking licence is activated for my user and the Booking application is authorized at company level

So far the links suggested above unfortunately did not solve the issue

@ekles402 @Jgrossiord will you be able to capture a network trace in the browser while this is happening and raise a support ticket with it. Please make sure "Preserve log" is enabled while capturing the trace. Please share the affected mailbox details as well so that I can confirm all pre-reqs are met. Feel free to DM me if you need any help with this.


The page https://outlook.office.com/bookwithme/me I get an error.

@Jgrossiord can you please share the error that you are seeing? 

We have the same issue, but the issue only appears when you don't have a bookings license BUT this also shouldn't be needed, only the creator of a bookings pages should need a license.

Use case:
- Admin of the bookings pages add me as a member (or any other role) of the agenda

- I received an email with the invitation

- Click on the link with "go to bookings" 

after clicking on the link, it will get in a loop between https://outlook.office.com/bookings/onboarding?src=mail-goto and


@ekles402 We are having the same issue, over the course of several months, at multiple locations, devices, and networks--seemingly tied to the individual. It behaves like whack-a-mole--will pop up sporadically for certain staff members, and then suddenly resolve after a few days. Obviously not optimal. 

I am having the same issue. Bookings will not load, it stays in a constant loop. PLEASE HELP @jamesacurtis 

I started having the same issue yesterday and it persists. I first noticed it when I clicked on a link to book time with one of my teammates but it happens on my own page as well. It worked fine the last time I used it a week or so ago.


Any help would be appreciated!


Yes, Microsoft please provide us some assistance with this.



It is doing it on any browser I used on my laptop. It is not happening on my desktop. So, it's apparently something on the laptop causing it but I am at a loss as to what that could be. It worked fine in the past.

yep.  same problem here.

Same issue for some of our users (not all). Have tried creating a new sharing policy and assigning it to trouble users, have removed Bookings from their apps and refreshed, no help.

Are we never going to get any kind of response on how to fix this?

One of my coworkers is having the same issue and needs to be able to update bookings. 

A confused Microsoft support rep on the phone surprisingly helped me fix this for one user.

  • We went to the user's licensed apps in the Azure portal (not 365 Admin)
  • Unchecked the radio box for Bookings app and saved.
  • Clicked "Reprocess"
  • Re-checked the radio box for Bookings app and saved
  • Clicked "Reprocess" again
  • Waited an hour or so and the user was able to fully access Bookings.



are you able to link to the azure portal referenced? i have been fighting with this problem but not sure exactly where you are talking about.. we only use azure ad. is it in that admin center?

@alecbobalec Yes, Azure Active Directory. Find the user in Azure AD. Follow my steps listed, but when I said "Azure Portal" I meant "Azure Active Directory"