Bookings stopped working

Copper Contributor

On Thusrday 17.5.2018 or Friday our Bookings partly stopped to work. On wednesday everything was working ok. The problem is when trying to get to Bookings Admin page, global admin users get this screen (below). Ask your admin is not a button. For our test account everything seems to work ok. Also customers can reserve times, but we can not modify the times and so on.


11 Replies
Yes, this caught me out as well a couple of weeks ago. Basically you need to add Business Apps (Free) to your subscription - you go through the 'buying' process even though it's free. You can then add Bookings to the App Launcher for the users as required.

Example steps here:

There is no Business Apps. We have educational license.

Then I'm guessing you don't have an A3 or A5 license, which is needed for Bookings? I believe Bookings would actually work from the URL on an A1 licence previously, but this was effectively unlicensed and has now been blocked.

Users have Enterprise Mobility + Security E3.

If you have E3 then you should be able to add the Business Apps (Free) as originally mentioned?

I have the same issue, but after I added Business Apps (Free), I still get the same page.  I have "purchased" the free license and assigned it to people, but still receive the same page stating that it is not enabled.  I have looked everywhere and can't find where it is not enabled. 

I purchased better license. It fixed the problem.


What is a "better license"?  The Business Apps (Free) is the only license you can purchase with O365 E3 that would include Bookings.   

I think E3 should be good.


That's the problem, it's not.  We have O365 E3, added Business Apps (Free) to get Bookings, which is still not working after assigning it to users.

I was running in to the same issue - E3 subscription with EO, Business Apps (free) license assigned to user yesterday, she's still getting the "Ask your Admin" page today. I was double-checking it while I wrote this, I realized that I hadn't turned Bookings on for the organization, under Services & Add-ins. Posting this for anyone else who gets stuck like I did.