Bookings, Phone Number, Customer Creation Problems

Copper Contributor

I’m having multiple MS Bookings Page and Customer Problems. I’ve added pictures to help clarify.


I manage 5 bookings calendars. This is happening with the 2 oldest ones. I use four fields, client name, client phone, client number, and county. This is a part of the Bookings page and when completed an appointment is created as well as a Customer in Bookings. I then link the outlook calendar to a third-party messaging system and clients get text message reminders based on the Bookings-created event.
The problems presented with the two oldest bookings calendars late last week.


The fields are properly filled out on the bookings page, but when the event is created they go under a generic notes section instead of the fields. Also, there is no customer created or recognized.


The system also adds a “0” to the phone number.


When I go in and delete the “0” from the phone number, bookings recognizes the customer creation and all is well.


I think it has something to do with some Customers-quota with Bookings so I manually deleted the existing customers making room for more. I had to do this one by one since there is no bulk customer deletion process. This has had no impact on the errors.

Picture 1.jpgPicture 2.jpgPicture 3.jpgPicture 4.jpg
Any input would be greatly appreciated. This system is vital to our process.

4 Replies
@kwald380, can you please clarify if the appointment is created from the booking page or directly from the Bookings calendar?

@davisjr Thank you for asking. It's from the Bookings Page. Doing "new booking" in the calendar itself doesn't seem to have the same problem. It's only on the published bookings page.

Another thing I've noticed is that when a user first goes to the bookings page, the Name field initially was blank when the bookings page was working correctly. Now when going to the bookings page the Name field is filled with the user of the workstation; e.g., it loads with my name in the field and I have to go in and delete and put the customer/client name there. That oddity seems to have started when the system initially stopped working correctly.

@kwald380 I am not able to reproduce this from my end. If you could DM me the booking page URL, that would help. In the meantime, can you please check these as well:

1. What happens if you update any field other than the phone number? Does it still fix the issue?
2. After you update the phone number, and you go to the Customers tab, do you see a new entry getting created?
3. Does this behavior have any bearing on whether you select a country code from the dropdown on the booking page?

@davisjr thank you! I'll DM you the relevant links.

 

1. What happens if you update any field other than the phone number? Does it still fix the issue?

Once I click "edit" in the Bookings Appointment and then click "Update Booking" the system fills the fields and creates the customer. It does this even if I don't edit the phone number. So the Customer Creation is linked to opening/updating the appointment within Bookings. Note that the phone number continues to have the "0" in front of it. 


2. After you update the phone number, and you go to the Customers tab, do you see a new entry getting created?

Yes, answered in #1


3. Does this behavior have any bearing on whether you select a country code from the dropdown on the booking page?

We do not have the country-code-dropdown as an option on the booking page. I believe it defaulted to the US based on settings in "Region and time zone settings" in the booking page settings.