Microsoft Edge not working when opening file

Copper Contributor

Hello Microsoft Team,

There is a problem when I try to access a file on a computer-downloaded pdf on Microsoft Edge. When I press a pdf file and go to bing, the page only resorts to "Shell Page", and tries to load indefinitely. The screen looks like a big "Bing" symbol with the phrase "just a moment".  


I cannot have the ability to view my document because of this,. Any help in solving this problem would be a huge appreciation. 


Thank you. 

3 Replies

@seanstyle I'm experiencing a similar problem too! Though it doesn't sound as bad as yours, it's only happened to me a few times, and not all of them involved PDFs. Have you tried using the browser's back arrow? The couple of times it happened to me that got me back to the PDF and let me view it.


P.S. Like this, right?

Annoying ShellPage.png

I am also having this problem but on just opening Edge from the launch icon
I get a black 'shell page' with the Bing Logo  'Just a Moment' and a progress bar constantly going round and round.
If I open a second tab I get the home page 
I'd rather it just worked on opening though

I have the same issue. It's pretty pathetic, to be honest. I barely use Edge; the only thing I ever trust it to do is open and edit PDF files, because I like how it lets you draw on them. But now it can't even do that without breaking.
For me, pressing the back button does work. But still, a broken redirect just shows shoddy coding, which is what I'm disappointed with.