Copilot for Microsoft 365 Tech Accelerator
Feb 28 2024 07:00 AM - Feb 29 2024 10:30 AM (PST)
Microsoft Tech Community
SOLVED

Whiteboard - Can't Sign-in/Sync with Work Account. Authenticator Keeps Popping Up.

Deleted
Not applicable

Hi All,

 

Whiteboard works for me in Teams and the Whiteboard app on Windows. However, on iOS, it keeps opening up Authenticator, but never truly signs in or syncs. This is for a work account. I've seen a comment in the Apple App Store with the same exact issue from like 1.5 months ago.....

@Ian Mikutel 

@Itai Almog 

15 Replies

@Deleted 

Same here, tried this week and does exactly that behaviour, just tried uninstalling and restarting my device, just in case :) and no luck.  It keeps requesting me to select which account to use in the authenticator. I can eventually get to the whiteboard, but if I try to invite anyone, it would invoke the authenticator, several times as I get the list of possible contacts, and then it doesn’t send the link over, or generates a link to copy.

I still need to do some troubleshooting with my team to rule out oddities with my setup: a) I have a BYOD ipad and b) I have my personal O365 account also added to the authenticator, maybe that confuses it? I did use WB successfully before with that personal account.  I saw last week Whiteboard working between the web versions as colleagues played with it, so it should work, unless someone in secops asked to disable usage from mobile and that is how it looks like (I wouldn't be surprised).

best response
Solution

@jespasan I solved my problem, but I don't know exactly why it solves it. I had to install the management certificates from the Company Portal app (bascially Microsoft Intune). That's the thing that lets your company set policies like password length, remote wipe on your behalf, etc. After that, no more problems with Authenticator. Whiteboard then works.

 

041319_0315_intunecompa3.png

@Deleted This will be fixed in an upcoming Whiteboard iOS app update on 6/17. 

Hi @Ian Mikutel , just for the record, it hasn’t fixed my issue... Whiteboard is still invoking the authenticator every step of the “create whiteboard” and selecting members, and never gets to actually send the invites to colleagues to join.

Would you know if the issue is meant to have been fixed? (if so I would probe our IT to do sth similar to what it was suggested in this thread, or fully de register and re-register my device etc.).

Thanks in any case.

Cheers!

JC

@jespasan can you please confirm the WB iOS version # in which you still hit the Authenticator loop issue? It should be fixed when running the latest App Store build. Thanks!

@Ian Mikutel 

Sure, it is 20.10615.0.5289

I have it in auto update and I can see that is the latest one in the app store.

I just checked and it keep invoking the authenticator :\

Cheers!

JC

 

Also running 20.10615.0.5289 and receiving the authenticator error...

dfuhriman_0-1594238094620.png

 

Not sure if this will be helpful for folks or not but I was finally able to figure out a way to get signed in. Here's my setup:

 

I have two "work" accounts (one personal, one actual work). Steps to reproduce/solve:

  1. Completely uninstall the app.
  2. Re-download and install
  3. Open the app
  4. Select 'work' when prompted to sign in. 
  5. Received the error I previously posted. 
  6. Downloaded the MS Authenticator app (but didn't actually do anything with it)
  7. Re-opened Whiteboard
  8. Was prompted to sign in
  9. Selected 'work' and proceeded. 
  10. Received a totally different error stating that the user I was attempting to sign in with did not belong to the tenant. For some reason my personal "work" tenant was already associated to Whiteboard and my actual work user of course does not exist there.
  11. Decided to try logging in with my personal "work" user --> SUCCESS
  12. "Signed out" of personal "work" user
  13. Was taken to a new screen that listed AD accounts where I saw my personal 'work' user.
  14. Selected the '+' option and was prompted to sign in with a work account.
  15. Signed in with my actual work account --> SUCCESS

 

Very odd and roundabout flow but it finally worked. 

@dfuhriman 

 

Yes this is it!

You need to install the MS auhenticator app (just install) and the login process to the work account works again.....

 

Bug.

 

To update on this, the way I solved it for my corporate account scenario was

a) I removed from Authenticator my personal O365 credentials, leaving just AzureAD from my employer's account.

b) Activated and added to the Ipad the MFA (before, it had only the AzureAD) so authenticator has now two entries from my employer O365.  I.e. I used the portal to generate the QR code and added it.

This fixed the issue fully, I could enter, create a whiteboard and send invitations

c) I added my personal authenticator credential and all seemed to keep working fine.

We did NOT uninstall, de-register/re-register or otherwise touch anything else.

 

The IT support colleague thinks it was just the lack of MFA account in the device.

Seems accurate, but I think I shouldn't need to register my BYOD ipad as an extra MFA device, every other MS app works fine with azureAD and where needed, they would ask for approval to my work iphone's authenticator. Why WB should be different? no idea.

Anyhow, now at least works.

@Deleted Same issue here and we're using another system for 2FA (IBM Verify) but this app still want to have the Microsoft Authenticator.
We're also using Maas360 for mobile device management and the next step is to deploy it via the app and SSO, let's see if this fix it.

But it seems that this app has another behaviour that other Office 365 apps when they authenicate.
Will update the result here.

 

@jespasan Hello All, This is my first post! I tend to search these blogs for answers and if you're like me, you get into a rabbit hole of trying just about anything. I found out how to get Whiteboard working on the iOS device. At first, I received the same error as seen in several threads. As the IT admin, this frustrated me. I tried the Company Portal (which opened a whole new rabbit hole for me) and it didn't work. I did, however follow these directions: https://docs.microsoft.com/en-us/azure/active-directory/user-help/user-help-auth-app-add-work-school...

I created a token here: Additional security verification after pressing the "+" icon in the Authenticator app. Signed in there with my school account. I then returned to Whiteboard, clicked on Work Account, and it synced with my school account. Hope this helps!

I am experiencing the same problem, but none of the suggested solutions could fix it for me.
I would be extremely happy, if I could finally use Whiteboard on my iPad with my current work account.

 

I am using:

  • iPad with iOS 14.5.1
  • Whiteboard App (latest update is installed)
  • MS Authenticator is running on that device

Accounts related to this:

  • current work account - set up in MS Authenticator
  • private account - set up in MS Authenticator
  • old work account from my previous employer - not set up in MS Authenticator (I believe I actively deleted that, when I left the company)

My problem:
Whenever I try to sign in with my current work account:

  1. I am asked for verification (password and approval in the MS Authenticator)
  2. I pass that verification
  3. I get an error message, which indicates that Whiteboard is trying to log me on with the account and credentials from my current work account, but it is doing that in the tenant from my previous employer where (of course) it cannot find me :(

I can log on (and log off and log on again) with my private account. This does not change the behaviour when trying the current work account.
Of course I have no access any more to my old work account.

 

What can I do to make Whiteboard log me on to the correct tenant or - in other words - make it forget that I ever used the tenant from my old employer?
I already did delete and reinstall Whiteboard.

same problem. I have a business account, all other MS Office apps on ipad. received the 'more value from your MS subscription' email, reviews whiteboard and downloaded it to my ipad. now I get this authentication error I have never seen before. please fix.
Did you find a fix for this. I have the same issue, it keeps trying to sign into the wrong tenant, so it fails.
1 best response

Accepted Solutions
best response
Solution

@jespasan I solved my problem, but I don't know exactly why it solves it. I had to install the management certificates from the Company Portal app (bascially Microsoft Intune). That's the thing that lets your company set policies like password length, remote wipe on your behalf, etc. After that, no more problems with Authenticator. Whiteboard then works.

 

041319_0315_intunecompa3.png

View solution in original post