Copilot for Microsoft 365 Tech Accelerator
Feb 28 2024 07:00 AM - Feb 29 2024 10:30 AM (PST)
Microsoft Tech Community

SharePoint Online Document Library Name and Spaces

Iron Contributor

There seems to be an issue with inputting spaces when creating a new document library. For example, if you want to put a space in between the capitalized letters, it will not let you - DocumentLibraryTest. If you hit the space bar in between it does not take it as input. 

 

Workaround:

 

Move your cursor in between characters after you have typed the document library name without spaces and then press the space bar.

6 Replies
Thank you. I have created a library and deleted it twice because it messes up the document template for this library.
Has anyone figured out what happened and when will it be resolved?
By the way thank you Tristan999. I thought something was wrong with my site or keyboard.
I'm not exactly sure when it will be fixed. Your best bet is to create a ticket with Microsoft.

Just ran into this problem today in the middle of a demo.  Thought I was losing my mind.  Glad to know of the workaround.  Hoping it gets fixed soon...

@Terry_Lazer You must have misunderstood:

 

I am talking about this field:

 

Tristan999_0-1654312304537.png

 

The bug is that the input field does not allow you to put in the space characters as you type the library name.

 

You need to put your cursor where you want to inject the spaces in the library name:

 

Tristan999_1-1654312392050.png

 

So, it is an issue. 

 

 

 

@Tristan999 

 

The issue also applies to the Description field, which is weird. My guess is that the Title tries to restrict spaces for the reason @Terry_Lazer gave, but the restrictions were also applied to the Description field, which feels like an accident.

 

Easier workaround

  1. Type a character into the input box
  2. Move your cursor before the character
  3. Type in your Title/Description (you can now add spaces if you want)
  4. When you're done, delete the extra character

@MehtaData,

 

It's definitely a bug.

 

From what I've read on the SharePoint reddit forum:

 

https://www.reddit.com/r/sharepoint/comments/ut8h5m/cant_type_a_space_in_new_document_library_name/

 

I've tried it on another tenant and the spaces work in both the Title and the Description. The one where it works is an E5 tenant vs where it doesn't work, an E3 tenant. You might have to pay extra for the spaces... :p joking.