Outlook (365) Need Password - Issue

Copper Contributor



We are using E3, outlook 365 in our company. Some of our users' outlook stop sync with exchange and ask for password, as shown in below image:


Password Issue - Copy.JPG


to fix the issue, I clear entries in Credential Manager, Delete Temporary Files, unchecked "Use Cached Exchange mode", restart system and check this again.


but after some couple of days, outlook again stop sync and ask for password.


I'll appreciate for any possible support to fix this issue permanently.



129 Replies



I had three machines with this same problem, and I too, followed all of the suggestions and spent countless hours over three years with multiple support techs.  One of those machines is now a Win11, and the prob is gone, but the other two I have just gotten into the habit of restarting them every other day.  I look forward to trying out your suggestion too.


Can you provide any more detail on your solution?


Thank you.

I have a machine doing the same thing - affects Teams and Outlook. They're on separate accounts, so I don't know if that's possibly connected. One thing that *is* strange is that BackBlaze (cloud backup service) quits updating/running hourly backup checks at the same time that "need password" bug shows up or "sign in" in Teams.

I've tried the registry "fixes", no improvement. I've deleted the AADbroker files, no help there either. This is a very frustrating issue, and feels like some background cryptographic service is failing after a few hours or days. Of course, no help in event viewer either, nothing of use is visible there. I'll check next time BackBlaze quits and look at event logs around that time, maybe there will be something more useful, but nothing shows up in event log when "need password" shows up in Outlook or Teams refuses to work with my account.

Okay, so here's a real head-scratcher. I tried both registry fixes, deleted AADbroker, all to no avail. BUT - I deleted both registry entries described in the "fixes", and now the system has been flawless ever since. What?? No issues in Teams, no issues in Outlook. Uptime is now 10 days. Most I could ever get before was about 3 days before one of the Microsoft services would quit. I have no way to tell if this actually corrected it or not, but if the "fixes" don't work for you, try them, and then remove those two registry keys. Who knows, maybe it'll break on the next reboot, but for now, the problem is solved. I still do run into some pretty massive memory leaks, where Explorer consumes about 1.6 GiB of RAM, but at least it runs stably.


I have been following this thread and have tried everything mentioned.  My customer, with the registry adds, goes down every 2 weeks (give or take a day).  Reboot usually brings him back.  Got him back up today so in a couple of weeks, if this happens again, I'll remove those registry edits.  Crazy problem...

If you're using Dells remove all of the Dell bloatware. Especially "Dell Optimizer"!! It solved so many Outlook & Teams connection issues for me.

I remove them all except Dell Command Update. 

In my case, I had to fix OneDrive first. Outlook "need password" was just a symptom of the issue. My OneDrive was messed up. Unlike Outlook, the OneDrive issues provided me with error codes and those were easy enough to chase down.

I@tsltsltsl   Interesting... can you tell us more about what you needed to fix with OneDrive?

@BEBakerit was a long journey through error codes and chasing them down online.

bottom line, sign out of OneDrive (unlink pc)  by clicking on the cloud in the lower right of the windows task bar associated with the account having the issue and go to settings then account.  then re-sign in (set onedrive file location to where it was before).   I was unable to do this and that is where the trail began.  Once OneDrive worked, outlook worked again.

Hello all!

I'm hoping my experience in this may help someone with something they may not have thought of...
July 10 2023 was the start of my hell period - started with one user being challenged for MS Password out of the blue - then one by one most of the organization started getting the popups almost every day or every other day. The sad part was that a small portion of our users started getting the dreaded "Outlook Loop" following by "Need Password" as the condition message (causing all Microsoft Products to fail by the way - including Teams and OneDrive.)
Opened about 4 trouble tickets with Microsoft during this period, with little or no solutions until the last agent, who was in contact with more senior support staff, asked what AV solution our organization uses. This location uses Trend Worry Free AV (Client/Server), and they suggested I "try it without Antivirus" - I initially balked as NOTHING changed in that area and couldn't have been caused by that but as a IT Tech myself I knew it was good practice to rule it out. We removed our corporate AV solution on 1 test machine with severe restrictions on usage and wouldn't you know it, all the problems went away! I was shocked - again NOTHING changed in our AV - no patches, no updates apart from the pattern files. (There were also no scheduled Windows update either - however the Microsoft Office Product offering is set to automatically install updates) The agent added that they have documented reports with customers with our same setup and the issue was the Antivirus. So Pass the buck time... I opened a case with the AV provider and in short order they had reports of this same issue as far back as May 2023 - they stressed that the problem is not just with their AV product but that it has been reported WITHOUT ANY aftermarket AV Solution! (implying Microsoft) Anyway for ANYONE that is curious what OUR solution was here is a synopsis of the Changes to OUR ANTIVIRUS SOFTWARE - Trend Micro:

I. Under Real-Time Scan / Scheduled Scan / Manual Scan> click +Add
Under directories in the Folders tab:
Antivirus/Antispyware, under files tab:

II. Under the Behavior Monitoring Approved List:

III. For Trusted Program List:
Trusted Program List > Add program full path

I can imagine the headaches out there after reading all your reports -
Thought I'd add this avenue in case it helps someone out there.

Good Luck!

This worked for me
This solution resolved my issue.

We have yet to find a solution to this issue.  We are not using Trend Micro.  We did add exclusions to our AV, SentinelOne.  No change.  We've even tried a test PC without AV on it.  No change.  We can 'resolve' the issue by deleting the C:\Users\username\AppData\Local\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy folder when the user is logged off.  But we can't keep doing this over and over.  This issue is a bane of our Help Desk.  Any other thoughts on how to resolve this issue?

@peter-supply  I have been working on this problem for nearly three years.  I have worked with at least four different MS technicians and the only thing they come to is that I need to start over and reinstall the OS from scratch.  Obviously, I can't do that, so I am left with having to reboot my desktop computer about every 36 hours.


I wish they could get this resolved.




Just a heads up that doing a PC wipe and reinstalling windows will not fix the issue.  We have brand new PCs that get the issue within a week or two of deployment.  Same goes for older PCs that have been wiped.

We encounter this issue in a Citrix server environment.  We are using Server 2022 and Office 2021 LTSC.  We tried Microsoft 365 Outlook- same problem.  We've tried Citrix UPM and FSLogix for account management- neither work to fix this issue.  Deleting the C:\Users\username\AppData\Local\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy folder while the user is logged out is the only solution we've found.  But this is time consuming for everyone.  We've worked with Citrix support and Microsoft support- neither have provided a solution.  For us, I think the problem involves Microsoft's switch from Azure Active Directory Authentication Library (ADAL) framework-based authentication to Web Account Manager (WAM).   No one seems to know how to fix it.  Very frustrating. 

In Summer 2023 it also started in our case. Thank you verry much for sharing your solution, it solved the problem completely.
I added the exclusions in out av solution (even though it hasn't detected anything in that folder) and deleted "C:\Users\<username>\AppData\Local\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy" for every user that had this problem. After that, outlook asks for the password one time and works just as it should.

I have been working on this problem for almost a year now and going through some of the possible solutions found here including yours.  Thankfully I came across this thread and was able to show my clients that it is indeed an issue that many are struggling with.  My main client experiencing this, the issue occurs sporadically.  He will run fine for a week... even two or three and then boom, he opens outlook and at the bottom, it says it is not connected to exchange and that it "Needs Password" yet we don't have the ability to enter a password.  The quick solution is a complete system reboot and he is back up for maybe another week or two.  I have applied this suggestion (removing \microsoft.aad.brokerplugin) today.  I'll know in a few weeks if it worked or not.  

Several months ago I reinstalled windows 11 and that fixed the issue. No more "Needs Password" and constant rebooting.

@MonikaS0913  thanks for the suggestion.  Unfortunately this clients pc won’t run Win11.  They are in the process of budgeting for new systems so here is hoping the problem goes away once they do.  Crazy thing with this issue is, everyone else with the same exchange settings etc., does not experience this issue.  Having said that, one user had it appear once and it has never returned for them since.  Spent hours trying to see differences… quite a rabbit hole.

Thank you. I have tried so many things with the tech reps and nothing has worked permanently. I look forward to hearing if your solution works long term.