Outlook (365) Need Password - Issue

Copper Contributor



We are using E3, outlook 365 in our company. Some of our users' outlook stop sync with exchange and ask for password, as shown in below image:


Password Issue - Copy.JPG


to fix the issue, I clear entries in Credential Manager, Delete Temporary Files, unchecked "Use Cached Exchange mode", restart system and check this again.


but after some couple of days, outlook again stop sync and ask for password.


I'll appreciate for any possible support to fix this issue permanently.



129 Replies

@MastahhThe solution above doesn't work, still need restart PC to fix outlook.

Back to Windows 98, Restart PC to make it working good again :D :D

Signing out of Teams and signing back on in Teams - then starting Outlook.  This resolves it for me.

This solution doesn't work, I cannot sign in into teams at all.
Error code - 80070008
Thank you, there was no key in the registery DisableADALatopWAMOverride (DWORD), so I added, and it worked.

@Muhammad Ali Khan I just worked on a system with the same issue. Go to settings,Accounts,  Email& accounts settings and remove the Email account you see listed there. Go back to outlook and it will ask you for the password.

Had the same issue after connecting to a different organization in Teams.
So closing outlook, signing out from Teams, sign back in with my company account and restart outlook solved the issue.



Did it resolve the issue long-term?  I could resolve the issue by rebooting the machine but it has always come back a day or two later.

@BEBaker as far as my experience goes this is linked to the multiple organizations you're connected to. So as long as you don't need to switch organizations it's fine but once you do it's back. So quit outlook, re-logon in Teams with your correct organization and restart outlook.


Just create a new User Profile and log in with the same outlook profile. it worked fine

It is a user Profile issue, recreating a new profile will be worked fine. and logging with the same outlook profile will fix the issue. it worked fine for me. just it once

I have this problem ongoing for months. Tried the registry hack that didn't work. Ran online repair and received error screen "Something went wrong". Online repair error.JPG 

Are you for real or just pulling our leg? Why on earth are we required to hack the registry then delete entire Outlook and Windows profile then recreate it all? That's a lot of work. Microsoft is required by law to correct these issues. Billions of people and businesses pay for their products hence Microsoft is required by law to provide an acceptable level of service. Not provide long and detailed workarounds for faulty software dirty coding or whatever. Of course they blame third party apps or someone and/or something else. In the meantime the end users are the ones left to troubleshoot and fix these issues themselves. Who pays for my time to fix this? Not MS that's for sure. @Christopher Hoard 

I have also been working on this with tech support for months. We ultimately got to the point of there being no way to fix this except restart my desktop everyday. I did that for six months and started a new tech support case and have been working with a new tech for the last 6 weeks. Nothing helped so far, but I have been grateful that the techs have not abandoned the situation. I hoping we’ll figure it out.

Are you using multiple organisations?
If so, this helped for me, so no need to do fancy stuff.

Quit outlook, re-logon in Teams with your correct organization and restart outlook.

I currently use the other organisations in an InPrivate window to overcome 'life' switching.
Here I do miss the alerts I would like to have and certainly if I'm mentioned somewhere but at least it is a 'workaround' for the other issues you get when switching organisations.

This is of course no excuse for MS not to solve this and to come up with a solution that helps us to switch organisations without problems.

Your simple answer has saved me days. Thank you for your time and effort. I will return you a favor by sharing with others the same way you did. Hope the sharing will continue endlessly and help improve our communities.
I have been working with multiple technicians at MS for over a year on this problem. We have tried so many different things and nothing has worked. The last step they wanted me to try was re-imaging my computer. As it stands now, I just have to do a hard reboot of my three computers with this same problem every day. But I know there are numerous people with the same issue and I just hope somebody stumbles onto a working, efficacious solution.
The solution I found for this problem that worked for me was to uninstall 365 and install Microsoft Office Professional Plus 2019. I logged into my personal account, setup email and it has so far worked without an issue. I am thinking the issue was to do with 365 Business Standard edition and I was signed in with a work or school account. I logged out of that account and uninstalled 365. Installed the Office pro plus and logged in with my personal account. My Exchange email account was setup through GoDaddy as they are my domain host and registrar. I think this issue is different for everyone else. Unfortunately Microsoft is so large they don't know what is going on and are unable to resolve their own software issue.
Thank you. We have uninstalled Microsoft 365 and reinstalled the current version and yet to no avail in my scenario. We modified the registry numerous times, recreated Outlook profiles, recreated Windows profiles, fiddled with TFA, credential manager, Teams Organizations, and nothing has been a permanent fix. The best solution is rebooting, and then all is good for about 36 hours when out of the blue, it will stop working because it needs the password. When you click on the error notification (in the lower right-hand area of Outlook), the password dialogue box pops up for a nanosecond, and there is nothing to do but reboot.

@Satoshi Nishimura 


It work after i removing my Office 365 account from "Access work or school" (Settings > Accounts > Access work or school) on Windows 10 solved that issue

@Neil_KEH  I am not sure I understand where you made those changes.  Inside Outlook?

@BEBaker   I did what Satoshi wrote and it solved my problem so I am writing here to share.

What was explained is that you need to configure SETTINGS in WINDOWS 10  not  SETTINGS in OUTLOOK.    Press windows button and type SETTINGS, then follow what Satoshi originally wrote.  Hope it helps.