Office 365 Mac Outlook: Cannot add delegate mail account.

Copper Contributor

Hello All,


I have given a user in my organization full-access to a shared mailbox. I would like to open the shared mailbox in his Outlook client on Mac. Following this guide:

Under account settings in the Outlook client I do not have an advanced settings button to get to the delegates setting pane. We have tried adding and removing the account many times. 
Looking at his mailbox options in the EAC, under the Exchange ActiveSync menu his Mac Outlook client is listed as a device and access is denied. This seems like weird behavior to me, I didn't think the full Outlook client on Mac should be using ActiveSync. Is there a setting or something I am missing? 

Any help is much appreciated. Thank you. 

14 Replies



Under Tool and Accounts, does yours look to be setup in the same way as my example below - set as an Exchange/Office 365 Account, but just missing the Advanced option at the bottom right?


Screenshot 2020-04-19 at 18.26.10.png



Unfortunately no. This particular account is set up as an "Office 365" account. See screen shot below. The only option I have is "Delete Associated Account." Thanks for the reply. 


Screen Shot 2020-04-16 at 8.50.47 AM.png




Interesting.  I've just setup another O365 account in Outlook for Mac, and it also defaults to Exchange / Office 365 which differs from what you are seeing.


Do you have another O365 account you can try setting up on the users Mac to see if the experience is consistent?



I have the same behavior on my end. I have been completely unable to reproduce this behavior. Only this account seems to be set up this way. 

We have tried deleting and re-adding about 5 times and uninstalling-reinstalling the outlook client. 


I find it interesting that I have an option to "Delete Associated Account." This leads me to think this account is somehow associated with another account but I have not been able to find anything that hits at that.   



Do you have a screenshot of the EAC settings you mention in your first post please?




Here are the mobile device details (EAC mailbox settings > mailbox features > Mobile Devices > View details):

Screen Shot 2020-04-20 at 7.38.50 AM.png


Here are the further details on the device labeled "Mac" above:

Screen Shot 2020-04-20 at 7.39.05 AM.png


I cannot find another example where a Mac Outlook client appears as a mobile device. I was under the impression mobile devices in the EAC was for phones only. I have tried granting access and deleting the device completely but as soon as he uses the Outlook client again it adds the device back and denies access again. 

This is clearly a phishing attempt do not click on this link!! is not a domain owned by Microsoft and was registered on April 20th with NameCheap Inc.



My own Mac appears as a mobile device in the same way in Exchange Online, but my status is unknown instead of denied.  It works just fine though.


Screenshot 2020-04-20 at 17.00.06.png



How about trying to create a new Mac user profile and setup the Outlook account in the new profile and see if it makes a difference?  Or try creating it on another users Mac, just to rule out the device?


@bsweetman @PeterRising It looks like your user is using "New Outlook", which doesn't appear to have the Advanced settings, or even allow Delegate Accounts.

The only way I've found to view Delegate Accounts is to turn off "New Outlook" using the switch in the top right corner (see attached) - Outlook will restart and you will regain the Advanced setting under Accounts.


New Outlook.png


It appears that even after adding the Delegate Account under the "old Outlook", switching back to "New Outlook" hides the account & related settings, so you'll need to avoid it for the time being.



Now that is a very good shout indeed! I can't believe I didn't think of that.  My mac is on the old Outlook.  I switched back a little while ago due to lack of functionality in the new experience.

@bsweetman I had the same problem when I tried to use the e-mail address. There are several e-mail addresses and aliases for one account. I have used rather than or and that worked without any errors. 

Any idea what that "delete associated account" is for? I mean what's the difference between the normal delete (minus) button on the left pane and this big "delete associated account" button. I have an O365 account and a personal Gmail account. This button is visible only on the Gmail one.

Just resolved this for my client.... turned out to be that they had Office 2016 installed, rather than Office 365. Installed 365 over the top and the settings came back.