Office 365 group calendar missing?

Iron Contributor

Ok, we dont know when this has happened.  But we created a Office 365 group via the admin gui portal. its been used as a document library and its the main teams group in MS Teams.  Now, the company wants to use the group 365 calendar.  however, when users are trying to access the calendar, its not visible in Outlook and when they try to use it online, it goes to their calendar.  In the URL, it has:<tenantIDName>/<office 365 group>/view/month


now, using the channel calendar in teams works.  Reading the channel calendar, it seems its a filtered view of the office 365 calendar.  which has been tested on another group and seems to be true.


we have called office 365 support and they are stumped as well.  


Is there anything we can do (powershell cmdlets) toget this working/visible?



22 Replies
I have exactly the same issue. The site/group has existed for a while so recreating it is not an option. The Group calendar just doesn't seem to exist.

@Suleyman Ali 

My problem is exactly the same as yours. It's not an option to recreate this site/group since it has existed for quite a while. Unfortunately, there doesn't seem to be a group event calendar.

Hi Sajid,

I have found the cause of the problem in my instance so I've place the fix below for you. Please check that this is actually the same problem before using the fix.

In Feb 2018 Microsoft by default HIDE email groups by default. What I found was that the group was there, but actually hidden. There is a way to list the hidden groups and then a way to unhide that group. The SharePoint groups I had that were not hidden were created before Feb 2018, those after wards are hidden from both the calendar and from the address book.

This solution worked for me

#Early 2018 MS stopped Groups from appearing in Outlook calendars or the address book by default
#If a SharePoint sites needs it's original Group Calendar or a Group Calendar is missing from Outlook then you have to unhide that group using Powershell.


#Connect to ExchangeOnline. You will be prompted to log in with your O365 credentials and MFA
Connect-ExchangeOnline -UserPrincipalName xxxxxxxxxxx

# Gets a list of all groups that are hiddenfrom*
Get-UnifiedGroup |ft DisplayName,HiddenFrom*

#Sets a group so that it is not hidden from Outlook or the address book
#Change "Group Name" to the name of the group to unhide
#Unhides the group from SharePoint
Set-UnifiedGroup -Identity "Group Name" -HiddenFromExchangeClientsEnabled:$false
#Unhides the group from the address book
Set-UnifiedGroup -Identity "Group Name" -HiddenFromAddressListsEnabled:$false


Thank you, Paul, for the PowerShell. I had the same issue and this worked perfectly.

Here's the kicker - even though I've connected to exchange online management via powershell, the set-unifiedgroup command consistently returns an error that it doesn't exist (though the get-unifiedgroup command works just fine).


Set-UnifiedGroup : The term 'Set-UnifiedGroup' is not recognized as the name of a cmdlet, function, script file, or
operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try
At line:1 char:1
+ Set-UnifiedGroup -Identity "Marcom" -HiddenFromAddressListsEnabled:$f ...
+ ~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (Set-UnifiedGroup:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException



Thank you for sharing the PowerShell commands!
Hi Dfoster303. I would recommend downloading the Exchange Online Powershell via the old ECP portal. You should then have all the required CMDlets.

Or try this guide:
I'm going to guess you have a commandlet missing from Powershell there somewhere that needs importing/installing.

That would seem to be the case. However, I've tried installing the Exchange Online Powershell module V1 and V2 to no avail. No one on my team can get any cmdlet with the word 'Unified' to work except for 'Get-UnifiedGroup'. After importing the exchange online module, we can run a 'Get-Command' and it returns no 'unified' cmdlets, save 'Get-' I don't know if it matters, but we are an all Azure environment, and do not have any on-premises Exchange servers.  @paulcreedy710 

Thank you! Unfortunately, we do not have any on-premises exchange server, so this guide is not applicable to my situation.


We don't use on premises exchange either. The Exchange Online Powershell module is an add on for the online version of exchange, not the on premises one.

You can still use built in Powershell but it gets complicated if the credentials you use have MFA enabled. The Exchange Online Powershell supports MFA as it gives you the appropriate prompts when you log.


Further down that article is a link from where you can download it. Here is the direct link

About the Exchange Online PowerShell V2 module | Microsoft Docs



You also get that error if the group you are targeting doesn't exist.

If you go into Exchange Admin to see the groups, it could be there's a typo on the name or the name you are using wasn't the one that was created. Groups can also have alias names which may not match the actual group name.

Does this bring back any results?
Get-UnifiedGroup |ft DisplayName,HiddenFrom*

Sorry, Paul. The problem is that I *am* using Exchange Online Powershell v2.0.6 (although I also tried this with 2.0.5 prior to today; updating did not resolve the issue). I can connect to ExchangeOnlineManagement via Windows Powershell or Powershell 7. In either case, when using the command:

"Set-UnifiedGroup -Identity "<groupID>" -HiddenFromExchangeClientsEnabled:$false"

I get the error:

"Set-UnifiedGroup: The term 'Set-UnifiedGroup' is not recognized as a name of a cmdlet, function, script file, or executable program."

If I run "Get-Command" I can verify that the cmdlet is missing from the list. It's not a permissions issue, as I am the Global Administrator. It's not a misspelling of the group name or the ID string. And yes, I am able to run "Get-UnifiedGroup |ft DisplayName,HiddenFrom*", and verify the group I'm attempting to edit is in the list. The "HiddenFromExchangeClientsEnabled" parameter is set to True, and I want to set it to False. Unfortunately, I can't because the "Set-UnifiedGroup" cmdlet simply does not exist. A conundrum indeed.




To be honest, I'm not sure what's going on there as it works for me; I've not had that issue.


If you put this as the first line in the Powershell script that you are running before you connect to Exchange does it make any difference:


Import-Module ExchangeOnlineManagement

Connect-ExchangeOnline -UserPrincipalName xxxxxxx


I also launched Powershell itself 'As Administrator' because our set up here is very locked down permission wise.


Are you using Privilege Identity Management (PIM).  I'm not for my user account but some posts I've seen elsewhere mention about having to additionally grant the Exchange online role.






Good morning, Paul,


Yeah, I've tried just about everything under the sun from as many articles as I can find. I always launch powershell as admin because almost everything I do with powershell requires it. We do use PIM, but not for my Global Admin account. I entered a support request to Microsoft, but haven't heard back yet. At this point, I've long given up and created the group a separate shared mailbox so they could have a calendar; just holding out hope that a solution eventually comes a long.


Thank you for all your help and suggestions :)

Going for the long shot here, could you try from a different workstation with Powershell installed etc installed or possibly from another global user account too. Just to rule out glitches with specific user or workstation permissions?

It seems one of those edge case scenarios, and permission or installation related.


Maybe even create another Global admin user just to try it out?

The issue is happening for everyone on my team. I just can't seem to narrow down the cause. I've been playing around with various roles in both AAD and Exchange Admin Center to try and track down the root cause, but my other Global Admin and both my Exchange Admins are having the same issue. Some of us are on Windows 11, but most of us are on 10. Everyone uses Windows Powershell, though I installed Powershell 7 on my machine to troubleshoot. It's clearly something organization specific - however, as I am the O365 admin, I cannot think of anything I'd have done that would have triggered this. I've had no other issues with Exchange Online Management. I'll keep digging around in my spare time and if I eventually figure out the cause/resolution, I'll post it here.
The "set-unifiedgroup" cmdlet has not yet been ported to the Exchange Online Powershell v2 module. If you are running v2, you'll need to uninstall the module by running "uninstall-module exchangeonlinemanagement" and then install v1 with the following command:

Install-Module -Name ExchangeOnlineManagement -RequiredVersion 1.0.1
This works for me