Office 365 Admin portal not loading

Occasional Contributor

For the past few weeks, I have had an issue with my Global Admin account in Office 365.  When I try to either go directly to the page from a shortcut or from the link after the initial login to, I get a notice that says:


We are sorry, something went wrong.

Please try refreshing the page in a few minutes. If the problem persists, please visit for updates regarding known issues.

Ref A: E3DE9C8F446146AC8D226D014C187207 Ref B: CH1EDGE0813 Ref C: 2020-12-09T14:24:48Z
If I hit the refresh it works eventually.  This happens regardless of the browser or the computer.
What I have done so for that didn't work:
1. Clear browser/PC cache and temp files.
2. Different browsers.
3. Tried incognito
4. Different PC (Not part of local AD, Azure AD) from a different Internet Service Provider.
What I have done that works.
1. Created a new Global Admin account and logged in with it.
So, it is my account, which was created in local AD and synchronized to Azure AD.  And yes, it is Domain Admin account.
What is worth noting, we added Azure to our account to start using it as well as AWS.  My account was not able to create anything in Azure even though it was listed as a Global Admin in Office 365, and inherited the Root permissions in Azure.  It would not take the role of Owner.  Even after adding all the admin permissions I could it still would not work.  I had to create another account unique to Azure to take on the Owner role.  Had Microsoft on the line for two weeks looking at this and they could not figure it out either.  We are going through a CSP, Insight.  Don't know if that matters.
Any thoughts?
2 Replies

@Michael Fulton Same and it's pissing me off. Be doing it for days on a number of my clients admin portals.

Well I resolved the issue but not sure if what I did actually fixed it or if its just a coincidence that the problem doesn't exist now.


Actually now that I think of it I did two things.

I had reloaded the OS on my home PC, which was having the same issues listed above, and I couldn't get logged into OWA or setup Outlook.  So I did the following:


1. I ran the "Microsoft Support and Recovery Assistant"  About the Microsoft Support and Recovery Assistant - Office Support

2. The assistant didn't resolve the OWA/Outlook issue so I found an article that said to make sure that your account (Mine is Global Admin in O365) is ONLY having the Global Admin permissions and not any of the others.  Mine had a few of the others listed which I removed. 

The Second one seemed to fix the OWA/Outlook authentication issue.  That was two days ago.

I noticed today that the issue of accessing the O365 Admin pages is not happening anymore either.  So hopefully this helps someone else out there.  

I would suggest making sure that you are ONLY listed as Global Admin and nothing else and try that.  If that doesn't work then try the Recovery Assist.


Even though this is a newly installed OS, my Chrome information is synced between work and home.  Plus the original issue happened even using incognito in Chrome.


 @Michael Fulton