No synchronisation of Subfolders to Mobile Devices

Copper Contributor

Hi everyone,


strange problem I ran into.


We did a migration for a customer from IMAP to Office 365. We exported the .pst-File, made a new profile in Outlook, added the Mailaccount (Office 365), everything works. After that, imported the .pst file and let it synchronize. Everything good so far. Outlook is fine. OWA ( shows all subfolders/mails we imported from the .pst file, so everything synchronized well. Standard procedure, we do this every week for several customers.


After a few days we started to add the Office365 (Mailaccount) to their mobile phones. They have mostly iPhones/iPads and some Android phones. Adding the mailaccount was no problem. Inbox etc. works, I can send and receive mails. And there comes the problem: There are no subfolders (the standard ones like Inbox etc. are there). They have some subfolders to organize their mails like "Accounting", "Orders", etc.


- In Outlook everything is fine

- In OWA ( everything is fine (all subfolders with mails show up, so sync was OK)

- On all phones, there are no subfolders/mails (those we imported with the .pst)

- If I create a new folder in OWA/Outlook it instantly shows up on the phone


Conclusion: The imported folders are "somehow flagged" to not sync with mobile devices. But they are fine in OWA, so the sync itself seems to be okay. I opened a ticket in the O365-Admin Portal but the support wasnt very helpful (they said it's the fault of the phones). I can clearly say it is not.


Any idea what to do next? Thanks in advance!

5 Replies
And this is happenbig on both android and iPhone ?
I know the android idé to have a ”see all folders ” option! Try sync with ”no limit” timeframe on IOS!

Hi Adam,


already tried the "no limit" option. Sadly it didn't work. Same thing on Android.


We also tried the Outlook App -> Same Problem. Makes things even more strange.

Thanks for your reply!

One common issue after export/import from IMAP is the folder type, which might be still set to IPF.IMAP and causing various troubles. So my question/suggestion is whether you changed the folder type after the import? You can use the macro here:

I've run the macro (the 2nd one), still no subfolders :\


Thanks for your help!

@Forke24x7 Have u found a solution to this problem yet?

I'm facing the exact same issue with one of my own customers