My signature stopped working in OWA

Copper Contributor

I'm using Outlook web through the latest version of Edge and my signature stopped showing in new/reply as of the 21/04. It only comes back if I open the "settings" area click on "compose and reply" and close the window. But if I navigate away from emails, say the calendar and come back it goes again.


Its been working fine for years and its starting to affect other users in our 365 tenancy today.  


Any ideas?  

39 Replies

Similar issue with Chrome @Noel1664 

Hi Learner6009, Is your 365 tenancy directly with Microsoft or through another provider? We are going through someone else. Its happening in Edge and Chrome.
best response confirmed by Noel1664 (Copper Contributor)

We found out that there is a known issue with the signature.  "Current status: We've determined that a recent Outlook on the web update introduced a code issue, resulting in the impact. We've developed and are validating a fix which we expect to be ready for deployment in the next few hours and complete by our next scheduled update on Wednesday, April 28, 2021." @Noel1664 

Nice move, we suspected some update may had caused this issue in the first place, we were reaching out to see if others were impacted. Thanks for coming back.

@Noel1664 it appears when the option 'add signature to all fwds and replies' is selected, no signature works, neither manually added or automatically.
so removed that option again...

one of the gazillion issues with ms365 which makes me advise googledocs way more than this

I'm continuing to have issues with my signature when using OWA. I thought this was fixed? Any news? Or adjustments I need to make on my end?
Have you tried clearing the cache on the browser? Its fixed now after the above update.
wasting time trying this, not even on another freshly installed browser...
We are still having this issue aswell, I see it was opened and closed in April:
We still have the same problem as well with office 365 OWA. We need to open settings, deselect the signature option and re select it again, then it work again, but when we close the browser and reopen it, the problem returns.
Same here. Still. :(
I wonder how many O365 users might be affected by this bug. It seems to have a low priority for Microsoft since they didn't see it necessary to ship a working fix asap. :o
We have the same problem as well with office 365 OWA.
Please Microsoft fix it!
It is now July and this is still affecting me. I have cleared my cache.


Possible workaround....

Open the email you're composing in a new window, using the 


button. When editing the email in the new window, use the "Insert signature" feature:-




This works for me.

I am having the same issue as others on this thread.  The signature will stop displaying on new emails, replies, or forwarded emails.  The Insert Signature button does nothing.  I have to go into settings and open the signature page then the next few emails will display the signature as expected.  Then it will disappear again.  Really frustrating and time-consuming for such basic email functionality to not just work.

It is now several months later and still having the same issue that was mentioned.  I have changed the options so many times and try to add my signature manually and still nothing happens.

I have tried even going through the rules and inserting a disclaimer and that doesn't always go through either!

What happened and how can this be fixed?


We fix the problem with Remove and Add back option in Exchange Admin Center: MyBaseOptions.
We try over online web page, but there was error, so we did it with PowerShell.
1. Import-Module ExchangeOnlineManagement
2. Connect-ExchangeOnline -UserPrincipalName
3. Get-ManagementRoleAssignment -RoleAssignee "Default Role Assignment Policy" | Format-Table Name,Role -Auto
4. Remove-ManagementRoleAssignment -Identity "MyBaseOptions-Default Role Assignment Policy"
5. New-ManagementRoleAssignment -Role MyBaseOptions -Policy "Default Role Assignment Policy"
6. Get-ManagementRoleAssignment -RoleAssignee "Default Role Assignment Policy" | Format-Table Name,Role -Auto

@Bojan_Nose, thank you for the reply.  I want to be completely up-front here so you know where I'm coming from.  I know enough about tech to be dangerous but I leave the tech-talk to the "computer people" who can really dig in and do what they do and understand each other better than I can. 


I understand using PowerShell from what you're saying, but since I have a hosted Exchange account and not an on-premise version, I don't know if I have PowerShell access.  And if I do, I wouldn't know how to even get that and would be concerned I'd mess something else up while trying to make edits!


So, what I'm hoping is that you or anyone else here may know what else to do other than hoping a fix will be available as I have no signature at the moment on my emails unless I copy/paste from other messages into the body of my emails which is not an ideal situation.


Thanks so much!

@jennglass , only the administrator of Exchange can fix this problem, contact your administrator.