Migration Endpoint problem 2010 to 2016 upgrade

Copper Contributor


We have Exchange 2010 Hybrid set up working just fine. All user mailboxes have been migrated. mail flow is happy. We still migrate a few new users each day (an old identity app). We're in the process of standing up Exchange 2016 and retiring Exchange 2010 and I ran into a problem:

I assume I need to run the Hybrid Config Wizard on my new Exchange 2016 servers. It works for a while then hits an error and stops. In the log, the wizard just loaded up all the Migration Endpoints for testing and all I see after that are errors.

When i go to a 2010 server's url https://<2010server>/ews/mrsproxy.svc -- i get notice about the service. so it returns something.

If i try that on the new Exchange 2016 server, i get nothing: http 400 error.

We have a VIP for migrations, when its pointed at 2010 it works fine. Mailboxes are migrated each morning. As soon as it is switched to the new 2016 Exchange server, it never connects.

While logged into O365 and VIP pointed at 2010:
Test-MigrationServerAvailability -ExchangeRemoteMove -RemoteServer mrsproxy.<mydomain>.com -Credentials $Cred
is sucessful

Pointed at 2016
i get errors:
Microsoft.Exchange.Migration.MigrationServerConnectionFailedException: The connection to the server
'mrsproxy.<mydomain>.com could not be completed. --->
Microsoft.Exchange.MailboxReplicationService.MRSRemoteTransientException: The call to
'https://mrsproxy.<mydomain>.com/EWS/mrsproxy.svc' failed. Error details: An error occurred while
receiving the HTTP response to https://mrsproxy.<mydomauin>.com/EWS/mrsproxy.svc. This could be due to the
service endpoint binding not using the HTTP protocol. This could also be due to an HTTP request
context being aborted by the server (possibly due to the service shutting down). See server logs for
more details. --> The underlying connection was closed: An unexpected error occurred on a receive.
--> Unable to read data from the transport connection: An existing connection was forcibly closed by
the remote host. --> An existing connection was forcibly closed by the remote host. --->

Autodicover has been moved to the new 2016 server and works just fine. ECP on this new 2016 server works just fine. I am missing somethign, but dont know exactly where to look.

Thanks for any suggestions

3 Replies

@Daniel Thompson  Just curious if you have a solution to this? Running into the exact error after upgrading Ex 2019 CU6 to CU8 (hybrid environment). 


Lots of time has passed and i only recently revisited this. But upgrading to CU18, (to apply the security patch) and downloading the newest Hybrid Wizard worked like a charm.
Not sure exactly what i was doing wrong, it was a while a go, but i think i tried to set this up without the Wizard.
Hope this info helps some.