Mail Delivery Failure to Mail-Enabled Public Folder

Occasional Contributor

Hello Fellows

I am setting up my Public Folders on O365 , But I am facing an issues since emails to this Public Folders gets failed with bellow error Message.


"Your message couldn't be delivered because the recipient is a public folder you don't have permission to send to. To fix this problem, contact the public folder owner or the email admin and ask them to add you to the allow list for the public folder."


here is what I have done and checked so far:

1-Mail is Enabled on Those Public Folders

2-Require that all senders authenticated is not checked on mail flow section

3- Domain is listed in Accepted Domains

4- I've tried both InternalRelay and Authoritative Mode non of them worked


Any help is much appreciated



3 Replies
best response confirmed by hntaurus (Occasional Contributor)

You need to adjust the default/anonymous permissions on the PF via Add-PublicFolderClientPermission.



@Vasil Michev 

Thanks for you reply

now I am getting this error , I tried with both Editor and CreateItems right

550 5.4.1 Recipient address rejected: Access denied. AS(201806281) []



RunspaceId : e2600f03-23be-4f24-bddc-1b25ea293b7e
Identity : \rew
FolderName : rew
User : Anonymous
AccessRights : {Editor}
SharingPermissionFlags :
IsValid : True
ObjectState : New

We have changed the the Domain Type to Internal Only and it works

Thanks for yout help