M365 Win 10 E3 activation issue

Copper Contributor



We have deployed M365 in a hybrid environment.

But we have problem to activate six computers with the Win 10 E3 license. 

We get this activation problem: 


The language above is Swedish, but it says that the subscription is active, but the activation has not been activated. The error code is 0x8007232b.


From the beginning these six computers had Win 10 version 1709 but they are now upgraded to 1803. They are all hybrid joined in Azure AD (with GPO).


I've read all the MS documentation (i.e. https://docs.microsoft.com/en-us/windows/deployment/deploy-enterprise-licenses#win-10-activated-subs...) but I can't find any solution.



I really appreciate if someone could help me :)


Kind regards,

Peter Holzinger

19 Replies

Please try to do a manual activation!  Read this document!





Please try to do a manual activation!  Read this document!





Thanks for your reply! I will test it on Monday. I'll get back here with the result :)

Great! Keep us posted!

Trevlig helg!



The problem is sadly not solved.

I tried to activate through the script at https://docs.microsoft.com/en-us/windows/deployment/windows-10-enterprise-subscription-activation

@echo off
FOR /F "skip=1" %%A IN ('wmic path SoftwareLicensingService get OA3xOriginalProductKey') DO  ( 
SET "ProductKey=%%A"
goto InstallKey

IF [%ProductKey%]==[] (
echo No key present
) ELSE (
echo Installing %ProductKey%
changepk.exe /ProductKey %ProductKey%


But nothing happened.


I guess it was that script you meant, Adam?





Also, check the following GPO:
“Do not connect to any Windows Update Internet locations" this should be TURNED OFF!




I have now turned off that setting through GPO ("Do not connect to any Windows Update Internet locations").

Then I ran the manual activate script again. It says only "Activating xxxx-xxx-xxx....", then nothing happends.


The status right now is that the "watermark" is gone, but in settings - activate it's still the same info. Error message 0x8007232B and info "Windows is not activated".


So sadyl, I don't think the problem i solved.


Do you login to the machine with the UPN?

Actually I'm not sure, I think they use the SamAccountName. 


I can try that as well.

Yes! Do that!


/ Adam



The problem, sadly, still exists.


More information about the situation.

I even try to activate with 

cscript.exe c:\windows\system32\slmgr.vbs /ipk NPPR9-FWDCX-D2C8J-H872K-2YT43

And also through the Settings - Activation (change product key). When I set the key as above, I get the following message:


We can't activate Windows on this device because we can't connect to your organisation's server. Make sure that you're connected to your organisation's network and try again. If you continue having problems with activation, contact your organisation's support person. Error code: 0x8007232b.



New information in this case is that the computer was bought with a Win 10 Home license. But I guess Win 10 E3 / M365 can handle it anyway? Or?


I have no more ideas at the moment, maybe I shall try to reinstall the computer.



I'm not really sure about this cause it needs a proper PRO license..

Please disconnect me from Office365. I cannot do that myself.

Option 1 

Microsoft E3/E5 needs Windows 10 Pro Licence on first to install Windows 10 Enterprise, if you didn't have W10Pro then you need to purchase and install that first. 


Option 2

"Cannot connect to server" this sounds like it has registered a KMS instead of a MAK key. 


See if it is looking for a KMS Server:

Open CMD as an administrator. At the command prompt, type the following command, and then press ENTER: nslookup -type=all _vlmcs._tcp>kms.txt

Open the KMS.txt file that is generated by the command.


Option 3

Sometimes there are registration delays in validating licences, keep trying and also check to see if the client isn't being blocked by your firewall


Option 4

the Microsoft E3/E5 requires the PC to be Azure Joined and the user to have rights to join Azure, make sure the registered user has permission in AAD. 


Option 5

Make sure the PC is up to date with the latest updates AAD has a minimum requirement

is updates fail, delete the Windows Update Cache and run this in elevated CMD

wuauclt.exe /detectnow /updatenow





My issue was that this computer was purchased with a Win 10 Home license. I've purchased a Pro-license and after that everything works fine.


Thank you all for your replies!



@Peter Holzinger- This was super helpful! We had a very similar issue. What ended up happening for us, was that the imaged machine was refurbished and the product key wasn't able to be queried via wmic due to the refurbishing process. To resolve it, we entered the product key manually based on what was on the sticker on the computer itself. After re-entering this key the Activation worked.

My client purchases WIndows 10 Home computers from big box stores. We run the update to Windows 10 Pro via the Microsoft Store ($99) then connect the computer to Azure AD as all users have Microsoft 365 licenses. I thought the upgrade would be to Windows 10 Business, so why does it show Enterprise and not able to activate? @Mark Masiak 

@Peter Holzinger 

I deployed customized Win10 Pro images via MDT.  Server 2019 are set up with a .local domain and UPN added for connecting to Azure Domain.  Once the machine (client PC with Win10 Pro) installed and joined the domain, as I assigned Microsoft 365 E3 + Win10 Enterprise E3 to the users (domain\user), the Win10 Enterprise activated.  My question is that the Office 365 installed via Office Deployment Tool still in GRACE period of 5 days counting down.

How to solve this issue ?

dsregcmd /status returned the Machine is Hybrid Azure AD joined.



the user needs to login to their Office 365 Account in Word/Excel


Either in the top right hand corner

Screenshot 2021-06-22 112927.png



Screenshot 2021-06-22 113243.png