Local Outlook Client stop updating Group inboxes

Copper Contributor

As seen on Spiceworks we and many other organizations are seeing this issue in the last few months:



Scroll down to the last 4 weeks and more and more people are seeing this.  Consistently the Web version is fine but the local version stops updating these folders. A delete of the outlook profile or OST fixes the issue for about a day and then it returns.


Tech support just runs people through the same steps over and over again, remove users from the group, re-add them. I like the person on Spiceworks had the same walkthrough.  It doesn't last, this is an Outlook client issue.


MS can you please acknowledge this as spicehead-7egyy stated in that Spiceworks thread. 

16 Replies

One of our customers is experiencing the same issues as described by Aus-MHCD

I raised a case with Microsoft the 365 support and their suggestion was:

You can try to do the following:
1. Make sure that in Account Settings-->More Settings-->Advanced Tab, the Download shared folders box is UNchecked.

2. Run Windows Update to make sure you have the latest updates for Outlook and other desktop apps for Microsoft 365.

3. Re-created the Outlook profile

I replied to Microsoft 365 support and advised that all of these steps have already been tried.

Re-creating the mail profile temporarily resolves the issue for about 1 day and then the issue re-occurs.

Several other people are reporting the same issues in this community forum:


I would suggest that this issue be internally escalated by Microsoft as there is clearly a bug somewhere with the Outlook Desktop Client and Office 365 Group email feature.

The only workaround for the users at the moment is to get them to use the Web Portal which is not ideal or else set the group to forward a copy to their individual inboxes.


Thanks conorc26 so much for your reply. :)


I have also raised a ticket (on March 31st) for our tenant and have not heard back from MS at all. As you said we get the same steps from the old support script and have done them multiple times for multiple users and it simply doesn't last.


I am very confident this is a bug with the local client version of outlook. We have the latest version of it, we have tried

  • both 32 and 64 bit
  • we have created new outlook profiles
  • we have unchecked the shared folder cache
  • we have removed the users from those groups and re-added them.
  • Happens with new groups, old groups

The one and only workaround that works so far has been have the users use Outlook Web.

So I agree, MS needs to escalate this.

I agree Aus-MHCD.

Definitely appears to be a bug in the Outlook Client.

Regarding my case with Microsoft 365 support these are the resolution steps I have been provided:
You can try to do the following:
1. Make sure that in Account Settings-->More Settings-->Advanced Tab, the Download shared folders box is UNchecked
2. Run Windows Update to make sure you have the latest updates for Outlook and other desktop apps for Microsoft 365.
3. Re-create the Outlook profile

I replied to them and advised all of these steps have been tried none of these steps are a resolution and that "Recreating the mail profile only works for around 1 day"

They responded with:

"Regarding your issue, as per our discussion, I did run diagnostics on our end on the affected users to resolve any syncing issue, please check and monitor the issue."

When I checked with the user's the Office 365 group emails are still not updating on their Outlook Desktop Clients.

Microsoft have since marked my case as "resolved"

I have asked them to re-open the case and suggested this needs to be escalated & investigated further by Microsoft as there is clearly a bug somewhere on the sync between Office 365 groups & Outlook Desktop Clients.
Have there been any further updates with this issue?

I noticed someone in the Spiceworks thread mentioning enabling MODERN AUTHENTICATION to resolve the issue. I'm wondering if this has worked for anyone else?
I did see that, I want to enable it but we have about 1500 users and am trying to figure out before I turn it on what this could potentially break and what all of our users are going to see so I can pass that information onto our helpdesk in preparation for calls.



We turned on MODERN AUTHENTICATION as described by ryanhedlof  in the Spiceworks thread

Office365 Group does not update in Outlook Desktop for one user. - Spiceworks

We did it about 3 hours ago, and it did fix the Groups mailbox sync issue for our client.
It is still early days, but nothing else has gone bump... yet...


Enabling Modern Authentication in Office 365 worked for me as outlined here:


The only issue the users have had was re-entering their passwords on the Outlook client.

So far so good.
Thanks for letting me know!
Hi - I have the same issue, though strangely it's only one folder, and I have a "number of unread" notification number showing on it, just not the emails. We already have Modern Authentication activated (and have done for a while) so that's not the solution for me.
Any other suggestions please?

Were you able to come up with a solution, @RuthRushton?  Or anyone?  Several of our users are noticing their group folders in the Outlook for Windows client are not syncing with the server (up and down).  All updates are installed and Modern Authentication is on.  I really don't want to have to delete and recreate everyone's profiles if that isn't a viable and long-term solution.  Any help and guidance would be appreciated.

Hi @Kennard1969 - I didn't find a solution though it does look like my folders now all update ok?!

Good luck, sorry I can't be more help.

Hi, did you manage to find a solution?

@Kennard1969 Have you seen any resolution or solutions to this?  This is hitting a lot of people in my tenant right now.  Modern Auth is enabled, I also have tried all the other solutions in the thread with nothing working long term.



This has been occurring to me since Monday. Users who are Members of the group have no problems, I am the Owner of the group. There was a co-owner of the group that was also experiencing problems, I changed her to a regular member and everything works fine for her now. Mine however still does not update on my remote desktop (Windows Server 2016), however on my local Windows 11 machine, everything is fine. I use the remote desktop 90% of the time, so I need it to work there. 

I have also rebuilt my profile this morning, and no change for me. Still doesn't work on remote desktop.

@AKSmedley, there was a bug in a recent update to the 365 apps that busted something in Outlook and screwed up the groups folders.  Try to update the app — when I updated today, it downgraded the version and the groups functionality was restored.



I rolled back my build 2 days ago to Version 2303 (Build 16227.20258) because that is the same build as my local computer where they show up just fine. The RDS was on 20280, but it says it's still on 20258 now and when I hit update it tells me I'm already up-to-date. But group functionality has not been restored. It restored briefly when I rebuilt the profile, but when I say briefly I truly mean briefly. Maybe 5 minutes. I'm running the officec2rclient.exe /update user updatetoversion=16.0.16130.20332 now to see if it works for me.


After going back 20332, it's working again. Although I still can't mark them as read for some reason. However, the version history says there are a couple builds between then and now and mine only broke 20280 was released. I noticed it Monday morning. So it's weird I had to go that far back.