Copilot for Microsoft 365 Tech Accelerator
Feb 28 2024 07:00 AM - Feb 29 2024 10:30 AM (PST)
Microsoft Tech Community

Issue deleting an archive

Copper Contributor

Hi there.

I have a user whose archive is nearly full.

I have run the commands from https://newsignature.com/articles/removing-and-creating-new-office-365-online-archive/ to delete it immediately.

Here are the commands that were run:

 

$upn = "Email address removed"
Disable-Mailbox -identity $upn -Archive
Set-Mailbox -identity $upn -RemoveDisabledArchive

 

However, when I run the command below:

 

get-mailboxLocation -user $upn | fl mailboxGuid,mailboxLocationType

 

I get this:

 

MailboxGuid : <removed>
MailboxLocationType : DemotedArchive

MailboxGuid : <removed>
MailboxLocationType : Primary

 

I have used these commands for other mailboxes in the past and it works correctly... once done when I run the get-mailboxLocation command I get only the primary mailbox.

And then when I enable archiving for the users, I get an empty archive mailbox.

For some reason, the archive for this mailbox is not being deleted and remains in the "DemotedArchive" state. If I re enable archiving, the full archive reappears (not an empty one).

Besides, I have searched the web for more info on this "DemotedArchive" state but did not find anything.

 

There is no litigation hold on the mailbox.

 

We had a hybrid setup before and the user was created on the on premise Exchange server. She was then moved to Exchange Online and later on online archiving was enabled. Since then, the on premise part was removed and our setup is now cloud only.

 

Can anyone please help?

1 Reply
Hi there.
I opened a ticket with Office 365 support and they were able to resolve the issue.