Hybrid joined some with owner, some without owners

%3CLINGO-SUB%20id%3D%22lingo-sub-2202444%22%20slang%3D%22en-US%22%3EHybrid%20joined%20some%20with%20owner%2C%20some%20without%20owners%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2202444%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Enot%20sure%20if%20this%20covered%20before.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ewe%20have%20setup%20Devices%20to%20Hybrid%20join%2C%20just%20having%20some%20inconsistency%20in%20owners%2C%20basically%20most%20devices%20have%20owners%2C%20but%20some%20don't.%20%26nbsp%3Bthis%20happening%20over%20different%20versions%20of%20Windows%2010%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ewhat%20is%20the%20correct%20behavour%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2202444%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzureAD%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

Hi,

 

Not sure if this covered before.

 

We have setup Devices to Hybrid join, which sync devices and registering them as expected.

Having some inconsistency in owners, most devices have owners, but some don't.  this happening over different versions of Windows 10, and isn't consistent with any version really.  windows 10.0 (19042) is okay in the main, but still have some without owners, it mainly other versions mainly do not have an owners.

As we plan to introduce SSPR too, I believe the users need be to a primary of device to be able to do this.

From the AzureAD list of device (not Endpoint).  selecting one of the device that is hybrid join with an owner, bring up the Properties, DeviceID, ObjectID etc, but the manage button is ghosted.  selecting a device with owner the mange button isn't ghosted

 

what is the correct behavour when a device is registered as Hybrid Join

 

and why can't I assigned a user to hybrid device with an owner

1 Reply
additional I have found if the devices doesn't get an owner, its does appear in endpoint, which means it does get any of the policies....i.e. windows update ring, compliance etc.

does anyone have any ideas how to correct the devices so that the current user it set to owner?

Thanks in advance