How do I access o365 powershell online

Occasional Contributor

Ok, so I work for a company that we use Gmail as our email system.  I'm responsible for divestitures.  A few days ago, one of the companys we sold to I was working on transferring their email to their o365 environment.  We were trying to get her o365 environment setup so our email transfer tool could connect.  When I was remotted into her PC, we were following some instructions.  (I've worked with PS for years on Exchange 2010.)  I don't remember how we did it, but we were connected into the o365 powershell within a webpage.  I thought it was through azure.  But, I have my own o365 business account and have my own azure account.  I cannot find an option to connect to powershell anywhere within azure.  What am I missing?

8 Replies

@nerddad Was it the Exchange Online PowerShell? To get this you go to the old Exchange admin centre then hybrid, then configure Exchange Online PowerShell


This then installs the module and opens PowerShell. It uses that "Click Once" installer so if you're lucky it'll work in Edge (it did for me just now, but never used to), otherwise you'll have to use IE.





(see attached) That kind of worked... I'm not seeing a whole lot of commands to run though.  What am I missing?  I placed my o365 on lit hold so I never loose emails.  I'm trying to get to the dumpster.

Still curious how I got to it on the web.  I thought we were in Azure on a website and we opened up PS directly within the webpage.  I'd imagine if I did this, I wouldn't have to monkey around with getting the right modules or ps-snapins or whatever to get all the available commandlets.  Granted it would be nice to do it this way too... then I could use ISE to script.  (I think ISE has been deprecated... but MS code or whatever they use these days.  My company is a decade behind the times.  So, I'm always being introduced to ancient technology.)

@nerddad Did you run Connect-EXOPSSession? Once you've done that you get all the Exchange Online cmdlets




I don't remember ever seeing an embedded PowerShell in Azure but I've never gone looking for one either so no idea where that could be.

@nerddad It wasn't Azure Cloud Shell was it? Just had a look in Azure and found a Powershell window within the Azure portal which sounds a bit like you were describing? (button to open it on the top near the right, if you've not used it on that tenancy before it'll ask you PowerShell or Bash and ask you to let it make a storage account)





Well, I thought I did that... but I just ran that command again and now I'm seeing all the commandlets.  I guess I should be good to go.  Now time to play around and learn.

Don't know if you happen to know... I put my mailbox on lit hold so I never loose anything.  In my own on premises Exchange, if the dumpster maxes out, I remove the quota on the database that the user is on.  (We never increase it... just remove it.)  But, doesn't  look like o365 will allow me to just remove the dumpster quota on my database... LOL.  So, I was trying to find another way for this to work.  What options will I have when this fills up?  I'm sure MS isn't too keen to allowing everyone to lift their quotas and have an unlimited quota.  So, I'm sure they're smarter than I am and thought of anything I'm going to think of.

@nerddad No idea I'm afraid, not something I've ever had to do.