Groups disappeared in Outlook?

Copper Contributor

Hi all,


As of late, my o365 groups are no longer visible in Outlook. If I use o365 via the web, they are accessible without issue.


No one else in any of my teams are experiencing this issue. We all run 2016 Pro Plus and connect to o365 Gov. I just attempted an Office repair to no avail. Will proceed with a reinstall next, but fear that won't help anything.


Any help would be most appreciated.



16 Replies

Group functionality in Outlook relies heavily on Autodiscover, so I'd focus my troubleshooting on that front.

Thanks Vasil, can you provide any additional context?

Thank you

Not sure what context you need. Like with many other functionalities, Outlook uses Autodiscover to fetch a list of Groups for the tenant, so you should focus on verifying that everything is working as expected with Autodiscover as the first troubleshooting step.

Outlook/exchange, not my thing. So when you say "verifying everything is working as expected with Autodiscover", where should I start? My email client works fine, which I believe is all Autodiscover.

You can start by running the test from Outlook: hold the CTRL key, right-click Outlook's icon in the tray, select Test E-Mail Autoconfiguration, clear the two Guessmart checkboxes, enter username and password and run it. Success should result in obtaining the XML file.

Thanks! Looks like I failed on webmail, but the overall result show success for Autodiscover and Redirect.

Post the results here so we can review them. Also, Outlook must be running in cached mode for Groups to work.

Am I missing something, or is there no way to save the Results or Log tab? Seems like only the XML tab allows you to copy, and it doesn't look as relevant as the other two.

Screenshot is fine :)

@adambean This happened to me just now after I disabled caching to perform a test. I noticed once cache mode was off the groups disappeared. I tried to restore it by reenabling the caching with full option chosen but it did not return. I then changed the setting to one year and the groups returned. I then dragged the slider to all and it stayed there.


I think there is a bug when you reenable it that isnt turning it back on but this seemed to fix it up.

@Brad Rush

This fixed the issue for me. Thanks a bunch!

Re-enabling cached exchange mode worked for me as well. I set it to 3 days.
Groups apparently disappeared at some point after I had disabled CEM.
This is an old thread but I just struggled with this and ended up contacting Microsoft Support after nothing I tried worked. It turns out that there is an attribute that controls whether or not the group is hidden from Exchange Clients. This sequence of PowerShell commands fixed it for me for this specific group. You will have to set each group's HiddenFromExchangeClientsEnabled attribute to false to see them all.
PS C:\> Install-Module -Name ExchangeOnlineManagement
PS C:\> Import-Module ExchangeOnlineManagement
PS C:\> Connect-ExchangeOnline -Credential $UserCredential
PS C:\> Get-UnifiedGroup -Identity "Support" | fl HiddenFromExchangeClientsEnabled
HiddenFromExchangeClientsEnabled : True
PS C:\> Set-UnifiedGroup -Identity "Support" -HiddenFromExchangeClientsEnabled:$false
PS C:\> Get-UnifiedGroup -Identity "Support" | fl HiddenFromExchangeClientsEnabled
HiddenFromExchangeClientsEnabled : False
This might explain the background as to why some groups are hidden from Exchange clients:
Thanks for the clarification. It took me two weeks to get that out of MS support (mostly due to scheduling conflicts). Thank you for taking the time to post the explanation. It's very much appreciated. I'm sure many others will benefit from it or, at the very least, save a few hairs.
This was the ticket here. Thanks, @VinhQNguyen!