External address error - recipiant primary SMTP is missing

Copper Contributor

Hello !


I work in a little company and we did our migration to o365 well, I start to get familiar with its potential and I hope some day I will see myself as an office365 Admin


I keep discovering new features, making my work much easier, but from time to time I have trouble to do something that I was doing in our old infra


So I was asked to add external email adress to a Distribution Group, I wanted to test the delivery first so I made a test account in the AD with my personal @gmail.com address as "Contact" status insted of "User", but when I try to send an email for a test I keep receiving a "No mail delivery system"


It makes me crazy because old externals address are working fine, I just can't reach new values


I also tried to create my "Contact" in Azure, it replicate fine since I see it in our Global address List after a while, but can't reach it always this "Mail delivery system"


I tried few things and keep looking for irregularity but I have no clue what is blocking me, the new external contact have same values than my older ones and still don't work


The question was never mentioned when we was in office 2016 and now we have an urge to fix this, do you have an idea folks?

3 Replies

I tried adding SMTP: as prefixe in my AD

didn't worked

Will you please provide the error message in detail?
Please provide the error, and if you can a little bit about how you route e-mail. Is the test being sent to this "contact" from on-prem mailbox or o365 mailbox? How is your outbound mail routed, is it to 365 and out, or from 365 to a spam device / gateway?