Exchange Online Hybrid Migration- Cannot create Migration Endpoint

Copper Contributor

Exchange 2013 Server. Ran Hybrid Wizard Successfully.  AD Accounts Synced through ADConnect.  Ran into a problem . Cannot create Migration Endpoint. Getting an Error " Connection to the Server could not be completed.

Checked all the settings. MRSProxy enabled.  Followed this link


Still No Luck.  Opened a Support case with Exchange ON PREM Team, they said no issue. Another ticket opened with o365 team.  Still couldn't figure it out.  Any inputs ?

9 Replies
I had this issue awhile back and went round and round with it and it was something stupid easy to fix but unrelated to the error message but I can’t find any email related.

You check on this it might have been this bit I can’t rememebr clearly it’s late. But think it was related.

Hi Niju,


Please follow the article that @Deleted said, but if you do not have the MRS Proxy active before the wizard the wizard only enable it, you will need to do a iisreset on the server to make it full available. I past few time was only the iisreset on Hybrid server the issue.

I already did IIS reset. I will try Chris Webb's Suggestion today to change the admincount attribute to 0 and restart the server this evening.   I will post the update here tomorrow.

You can't just change it, you have to see why it was set to one, checking those groups and making sure it didn't get added to another group. I had this issue cause I added the computer to another group when messing with something related to DAG a long time ago and didn't know it. And figure this out somehow before this article existed, but make sure you check that computer for all the groups it's a member of and check it out.

Computer account is a member of only following groups...

  • Domain Computers
  • Exchange Install
  • Exchange Servers
  • Exchange Trusted Subsystem
  • Managed Availability Servers


Found adminCount attribute was set to 1, Changed it to 0, Restarted the Exchange Server... Still the Same!! No Luck!!

I tried all the Solutions and running:tired_face: out pf options now 
Opened a MS Ticket, still no luck..
Re ran the Hybrid Wizard, Isolated Firewall,  But still cannot create endpoint... If anyone can help me today, please let me know. Its Urgent!!
What did you get when you ran Test-MigrationServerAvailability from Exchange Online PowerShell? You did not post the message here, so it's very hard to guess to assist you.

We found a resolution at last.   And got it resolved.


Exchange On prem Server was giving a permission issue with Token Serialization.

 Event ID 3002,