Classic Exchange admin center redirect loop and exo powershell access denied

Copper Contributor


Powershell gives me an access denied error when attempting to connect to exchange online (V2 module). When I run Connect-ExchangeOnline I get prompted to login. I put in username, password, and MFA. Powershell then throws the Access Denied error. This only happens for exchange as SharePoint connects without issue.


On a likely related note, when I attempt to go to the classic exchange admin portal it gets stuck in a redirect loop until it stops with an access denied. This happens regardless of browser and with an in-private/incognito browsing window. The new exchange admin center is unaffected, and all other admin centers work fine, this is specifically the classic exchange admin center only.


I am a global admin and do not have other roles assigned.

This was working a week ago and no changes were made to the tenant config or users around the time the issue started.


Any ideas on how to fix this? Or why only classic exchange admin and exchange powershell are affected?

2 Replies
Might be something server-side, so best open a support case. To exclude possible issues on your end, I'd also suggest trying the EAC with a private browser session, or connecting via PowerShell in a new profile. Testing from a different location will also give you some clue as to any network-related issues.
I tried the in-private tab, and different browsers, to no avail.
Strangely enough my login did work in PS from a different machine and it can open the EAC.
My machine can also connect to a different tenant, just not my work.

So it looks to be specific to EXO PS and classic EAC, only this tenant, only this machine.