Unable to delete files from group

Occasional Contributor

In our group, we have a menu ' files' .  When I click on that menu, I see the files in our group. I can select the files, but there is no option to delete them. When I click on ' browse throug library'  on the top right, a newe window opens with the sharepoint library.  I see a folder ' general'  with our files in it. I can delete the files here, but when I go back to the group, the files are still there.... I also tried to empty the bin in sharepoint, but with no result.


How do I delet files from a group?

3 Replies

Solved. It seems like a bug: you have to click on a file that is deleted. You get an error message that the file doesn't exist. After that, the file isn't visible anymore.

The Files view in a Group does not provide the ability to delete a file so you have to do it through the SPO site as you have done. What it's true is that the deleted file should not appear in the Files view if it's deleted in the SPO Group site.... @Christophe Fiessinger FYI

best response confirmed by R. Jong (Occasional Contributor)

correct that's by design today and it's something we are planning to address in the future (adding the "delete" gesture among other things).