Some O365 Groups not appearing in Outlook Client - Hybrid Exchange

%3CLINGO-SUB%20id%3D%22lingo-sub-91917%22%20slang%3D%22en-US%22%3ESome%20O365%20Groups%20not%20appearing%20in%20Outlook%20Client%20-%20Hybrid%20Exchange%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-91917%22%20slang%3D%22en-US%22%3E%3CP%3ESo%20just%20checking%20if%20there%20is%20a%20solution%20for%20this%20-%20I%20suspect%20it%20is%20an%20Auto-Discover%20thing.%3C%2FP%3E%3CP%3E*%20Hybrid%20Exchange.%3C%2FP%3E%3CP%3E*%20MX%20Records%20point%20to%20on-prem%20%2F%20non%20O365%20email%20filters.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ES0%20when%20I%20create%20an%20O365%20Group%20-%20and%20it%20defaults%20to%20the%20Groupname%40tenant.onmicrosoft.com%20address%2C%20it%20eventually%20appears%20in%20the%20groups%20section%20of%20my%20Outlook%20Desktop%20Client%20and%20works%20fine.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESoon%20after%20changing%20its%20Primary%20SMTP%20to%20our%20own%20domain%20%22Groupname%40conoso.com%22%20(while%20still%20maintaining%20aliases%20to%20onmicrosoft.com).%20Those%20groups%20disapear%20from%20the%20Outlook%20Client.%3C%2FP%3E%3CP%3EThey%20all%20appear%20OK%20still%20in%20Outlook%20Online.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAre%20we%20doomed%20until%20we%20stop%20our%20Hybrid%20config%3F%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-91917%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EGroups%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-91987%22%20slang%3D%22en-US%22%3ERe%3A%20Some%20O365%20Groups%20not%20appearing%20in%20Outlook%20Client%20-%20Hybrid%20Exchange%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-91987%22%20slang%3D%22en-US%22%3E%3CP%3EThere's%20a%20long-standing%20(known)%20issue%20with%20Groups%20and%20Hybrid%3A%20%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Fhelp%2F3168347%2Fusers-in-an-exchange-hybrid-deployment-can-t-access-office-365-groups%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Fhelp%2F3168347%2Fusers-in-an-exchange-hybrid-deployment-can-t-access-office-365-groups%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

So just checking if there is a solution for this - I suspect it is an Auto-Discover thing.

* Hybrid Exchange.

* MX Records point to on-prem / non O365 email filters.

 

S0 when I create an O365 Group - and it defaults to the Groupname@tenant.onmicrosoft.com address, it eventually appears in the groups section of my Outlook Desktop Client and works fine.

 

Soon after changing its Primary SMTP to our own domain "Groupname@conoso.com" (while still maintaining aliases to onmicrosoft.com). Those groups disapear from the Outlook Client.

They all appear OK still in Outlook Online.

 

Are we doomed until we stop our Hybrid config?

Thanks

1 Reply