Force delete Group Site Collection after Group Deleted?

Silver Contributor

I don't suppose there is a way to force delete a site collection after the group is deleted?


I created a test group that happened to use the name that I now need to use.  I deleted that group days ago.   It will create the group if I try to use the name I need, but appends a number to the end of the site collection (in this first case 69)


Dont see a way in UI, powershell doesnt work, a bit frustrating.

63 Replies

coincidentally I've just now realized that the site of a group I deleted months ago still existed. Will delete it manually tomorrow :)

@Nicholas Byng-Maddick wrote:

We have the same situation with groups being apended with other numbers and are looking to tidy up these groups. Interestingly trying to use the delete option and despite being Global Admin and Sharepoint Admin I am refused permission to the site.


Has anyone experienced this or do I need to be Exchange Admin to acheve this deletion ?

I have the exact same thing happen to me, did you found a solution?

Please open a support with ticket so we can get this fixed.

I have a feeling that one of our admins manipulated the standard delete URL to get to relevant SPO function. I don't have a spare Team/ Group to test on though.

I have alreay tested that and I got the response that I wasn't allowed to do that and gave a form to request permission but I supposed that form went into a black hole or something.

I think it was the owner of the Group that performed the action and hence was authorised. Otherwise you probably need a SharePoint admin to have required permissions..

But I am global admin and both created the group and deleted it but I got support from microsoft today and from powershell it was no problem to remove it. The commands that I used from SharePoint Online Management shell was connect-sposervice and remove-sposite

This worked for me as well - thanks for the tip!! In my case, the other orphaned sites were not deleted -- I have one group site I couldn't delete (hence the searching that landed me on this thread), and a test group site I created to debug the issue. My test group site deleted just fine with your method, the original group site stuck around.

This has never worked for me. I believe I reported this when we were still using Yammer Group for communication. 4-5 months ago?

This whole thread makes me think that a lot of this on the backend is some sort of sync process, and I generally hate sync processes as they tend to always break or get "stuck" :) Is the team watching the failure rate of these sorts of actions to prioritize ways to improve the reliability? Nothing erodes user confidence faster than an action they see as simple, like a delete, not functioning properly!


We all know how complex this actually is, but explaining that to a user nets you "the look" which I'm sure you've all seen. This stuff needs to become bulletproof over time.

There is an other thread on this problem:


I just posted a solution that helped me:

First unlock the SharePoint site:

Set-SPOSite -Identity https://<name>/sites/<sitename> -LockState Unlock


Then add your global admin account:

Set-SPOSite -Identity https://<name>/sites/<sitename> -owner <your global admin account>


Then delete the site.


Oh Henk you rock! before 4 hours I can solve this with your method. Thanks!

Very helpful. Had some sites get hung after group deletion and this does the trick

Not working for me


spo not working.png

Perfect... it fix the issue..




Hi @Brent Ellis!

I have a similar issue.

I created an Office 365 group, which automatically created a team site.

I deleted the team site and the group manually, and now I cannot reuse that url in a new team site because Office will add some random numbers at the end. However, if I try to access that URL I get a 403 FORBIDDEN error because the group has been deleted.

Anybody knows how I can get back this url??


Looks that the site was inaccessible, but it still existed.


Had to use PowerShell to delete it and free the url.


Followed @Henk Luggenhorst instructions:

First unlock the SharePoint site:

Set-SPOSite -Identity https://<name>/sites/<sitename> -LockState Unlock


Then add your global admin account:

Set-SPOSite -Identity https://<name>/sites/<sitename> -owner <your global admin account>


Then delete the site.

It worked great :)

Thanks a lot!!

A few steps missing in this explanation


First you need to download and install the SP snap-ins for Powershell


Then you can execute the SP commands in PowerShell. The next command must be run on the -admin site of your tenancy:

Connect-SPOService -url https://<yourtenancy>

 Then finally you can run the commands mentioned before for the deletion of the site:

Set-SPOSite -Identity https://<yourtenancy><site> -LockState Unlock
Set-SPOSite -Identity https://<yourtenancy><site> -owner <>
Remove-SPOSite -Identity https://<yourtenancy><site>


Hope this helps!


Here is what I noticed, though: This seems to be a problem when a group is created via Yammer and then pushed from Yammer into O365 as a group. At the time of this writing, O365 does not support creating an O365 groups that is then pushed into Yammer.

Thanks for the info.

Very simple and effective description to follow. Well done Pedro!