Admin center for Outlook Groups?

Brass Contributor

Hello, I'm new here. I'm having problems with's Shared calendar (sync does not work anymore) so I'd like to use Outlook Groups instead.

First things first, the Outlook Destop app does not allow me to edit many group options, so I'd like to know if there is a web based "control panel" for my Outlook group?

I need to edit my group's email alias.



7 Replies
Group e-mail alias can only be changed using PowerShell

Below cmdlet, will set the new primary email address for the group.

set-unifiedGroup -Identity <GroupName> -PrimarySMTPAddress <new email address>


To remove the old email address, run the below one along with the first cmdlet.

set-unifiedGroup -Identity <GroupName> -EmailAddress SMTP:<newemailaddress> 

Hi, thanks to you both.

I tried to run :

set-unifiedGroup -Identity "My Group" -PrimarySMTPAddress ""

and here is the error message I got :

set-unifiedGroup : The term 'set-unifiedGroup' is not recognized as the name of a cmdlet, function, script file, or
operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try
At line:1 char:1
+ set-unifiedGroup -Identity "My Group" -PrimarySMTPAddress "myemail ...
+ ~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (set-unifiedGroup:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

Is there something I should do before running the commands?



First you need to connect to Exchange Online through powershell remoting.

Thanks this has worked perfectly, however in Outlook Desktop app, the alias is not updated, and the member list is empty. It kind of lost the link to the group... How can I fix this? Thanks

I have tested the script again here and checked, the member list is not empty. Can you post the screen-shot of the page with empty member list?


To change the alias and display name of the O365 group, use the below PowerShell script.


set-unifiedGroup -Identity Engineering -DisplayName Engineering2 -Alias Engineering2

Hi Narasima, thanks again for the help.

In fact after several hours and several restarts of Outllok, all went well: the alias and the member lists were updated. I just had to be a bit more patient :)