Word for Mac File > Share > Send Document Doesn't Work

New Contributor

Microsoft Word for Mac Version 16.55 (21111400)

Mac OS Monterrey 12.0.1 (21A559)

 

When I pull down File > Share > Send Document, Word gives a "donk" (error) sound.  Same thing for File > Share > Send PDF.  When I do File > Share > Send HTML, the system opens Outlook and appears to prepare an email message to send the file.

 

Any suggestions?

 

By the way, Outlook is not my default email program.  A different email program (Spark) is designated for my Mac, using the prescribed but odd way to do that: open the Mac Mail app, and pull down  preferences (for Mail), and in the General tab specify the default email reader.  

15 Replies

Same here, I'm actually using Postbox as my mailclient but the error is not inherent to any emailclient: the bug/error issue actually happens with all emailclients, including Apple mail.

The only workaround is to save the Office-file and manually attach it to a new email.

Very annoying. Reading various similar responses, it is not clear where the issue arises: in MacOS or in Office365.

 

I hope soon the issue will be solved.

@ortnpalms 

I am having the exact same issue using Spark. It used to work but the problem started about a month or so ago. Very annoying to have to do it all manually.

I am having the same issue and I AM using Outlook as my default email program. Help.

This just began for me after updating my system to Monterey...not sure if there is a connection or just a coincidence. I'm using Mimestream as my email client.

 

By the way, I just checked and I'm also getting the same problem in PowerPoint with the "Send PDF" option. 

I think that this may be a result of an incomplete implementation of Object Linking or Embedding (OLE) on a Mac. OLE is a Windows feature that lets one program embed (or link) information within another.  For example, if you want to link (embed) a .pdf file in an Excel file on a Mac, you can't do it.  You can't link an MS Word document in Excel for Mac, but not a .pdf file or any other file as far as I can tell.  Whose fault is this - Apple or Microsoft?  Decade-old posts on the web claim that Microsoft refuses to release the technical details of OLE to software developers.  If this is an OLE problem then I'd say it's Microsoft's fault and good luck in ever getting it fixed for Macs.  

I was able to fto fix this by choosing microsoft outlook as my default mail client in the preferences of the apple mac default mail client. Prior to that only send as html was working. After that send as doc aslo started working...I am on Monterey

Try reseting outlook as your default mail client in the preferences of the apple mail app. that worked for me.

I can confirm that resetting my default email client back to Outlook restores the "File > Share > Send PDF" option......but only using Outlook. 

 

It used to work even with other email clients. That's the issue. 

I have tried the recommended resetting default mail client and that didn't work. I also rebooted, opened and closed Mail, Outlook and Word. Any other suggestions?

thank you so much It also worked for me : I went to the mac mail preferences, and changed the default mail client to outlook, and it worked !!! @robinchatterjee 

@ortnpalms , I am sure you have resolved this now; this happened to me after installing edge (to have a smoother operation with my company SharePoint). The system changed my default email reader to edge in the apple mail preferences. I Changed that back to outlook, and everything works again. Thanks to the guys below for pointing that out!

@ortnpalmsI have tried revisiting the default settings in the Mail program for e-mail service, but it was already set to Outlook.  Once I set it to Mail, then it would attach the document to a Mail e-mail, but won't work with Outlook.  I prefer Outlook, but at this point will be sending e-mailed documents from Mail.  Weird.

 

Nick

 

same problem for me! please help..

@ortnpalms With all due respect, I don't want to use Outlook or Apple Mail - I want to use Spark.
It's seems rather protectionist to only support Microsoft's preferred client and Apple's proprietary version.

@domenico_vecchioneI have the same problem - if I switch to Mail it works but when I switch back to Outlook it doesn't