Unable to "Open in Excel", "Open in Word", etc from SharePoint Online in Chrome

Valued Contributor

This works for some people, and worked for me in the past.  But I am no longer able to:

  • "Open in Word"
  • "Open in PowerPoint"
  • "Open in Excel"

 

Using Office 365 Pro Plus, Deferred Channel, using Chrome 32 bit (up to date).

 

If I open a file, it will open in Excel Online first, then I select "Edit in Excel", i'll get an application handler popup, but then nothing happens.  This is the same result for Word, Excel, PowerPoint, Skype for Business (joining meetings).

 

I've tried uninstalling and reinstalling Office 365 Pro Plus and Chrome several times now.

 

Can anyone think of anything to resolve this, or has anyone run into this before.  Its a bit perplexing.

2 Replies

What OS - Windows 10?

 

Have you tried resetting the default file associations?

 

Does it work in IE11?

 

This might not help but there have been instances in the past (as recently as Feb 2016) with people reporting the same behaviour with Chrome https://bugs.chromium.org/p/chromium/issues/detail?id=230316#c16

 

-Sonia

It might be caused by one of following two reasons:

 

1. Hanlder not registered.

You can confirm it out by two ways: 1) If you are in edit mode, switch your word online into "view mode"(view -> reading view) and click "edit in word". 2) Go back to sharepoint file list view, select the document and click "open -> open in word" in the top menu.

 

if handler problem is confirmed, you can follow this link to manully fix it: http://forums.mozillazine.org/viewtopic.php?f=38&t=2899199

Note: the registry value could be different based on the office version, you could find another workable machine for reference.

 

2. If hanlder is working fine, it might be caused by browser's pop-up blocker, which blocks pop-up in edit mode of word online. You can disable "pop-up" blocker in your browser settings and try it again.

 

Hope above helps!

Thomas